5

I like using sections as bookmarks when editing. However, when I use achemso it turns these off.

MWE1 produces bookmarks properly.

%\documentclass[journal=cgdefu]{achemso}
\documentclass{article}

\usepackage{hyperref}

\title{This is a title}
\author{Canageek}
%\affiliation{Department of Chemistry, Simon Fraser University, 8888 University Drive, Burnaby, B.C., Canada}
%\email{This is an email}
\date{}

\begin{document}
\maketitle
\section{Introduction}
\section{Experimental}

\end{document}

MWE2, however, does not:

\documentclass[journal=cgdefu]{achemso}
%\documentclass{article}

\usepackage{hyperref}

\title{This is a title}
\author{Canageek}
\affiliation{Department of Chemistry, Simon Fraser University, 8888 University Drive, Burnaby, B.C., Canada}
\email{This is an email}
\date{}

\begin{document}
\maketitle
\section{Introduction}
\section{Experimental}

\end{document}
5

The standard settings in achemso turn off section numbers by effectively making \section behave like \section*. You therefore need to use \SectionNumbersOn to enable section numbering: this will also generate PDF bookmarks for the sections. If you want numberless sections but also want \SectionNumbersOn then you'll need to use \section* in place of \section, as in any other document.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.