14

I just updated my MiKTeX instance to the latest packages and am using the LuaLaTeX compiler. Whenever a document relies on pgf I get the following error:

! Package pgf Error: Driver file ``pgfsys-luatex.def'' not found..

I found this Bug report, https://sourceforge.net/p/pgf/bugs/384/, where someone provides the missing file (he simply renamed another driver and did little changes apparently), but this really doesn't solve my problems. The missing file error goes away with this driver, but for example setting aspectratio=169 as a beamer option is fully ignored while it worked perfectly fine with LuaLaTeX before the MiKTeX update.

A minimal example would be:

\documentclass{article}
\usepackage{pgf}

\begin{document}
Compile me with lualatex.exe
\end{document}

With the driver from the linked bug report and the following MWE:

\documentclass[aspectratio=169]{beamer}

\begin{document}
Foo
\end{document}

I only get the default Aspect Ratio of 4:3. Before the MiKTeX update I correctly got 16:9, even with LuaLaTeX.

I tried purging and reinstalling MiKTeX. It did not help.

How can I compile pgf-based documents with LuaLaTeX correctly again?

  • 1
    It is quite unclear what problem you have -- your example compiles fine if I add the missing driver. But the standard answer to all sort of luatex problems is currently "add \RequirePackage{luatex85}" (at best before \documentclass). – Ulrike Fischer May 11 '16 at 21:06
  • note the new luatex is more or less completely incompatible with pdftex and all previous versions of luatex, that's why it has a version number less than 1 and says beta in its startup banner, interfaces are not fixed and can and do change. a lot of peopel have updated a lot of packages to hide most of the issues but breakage is expected as the new version rolls out. – David Carlisle May 11 '16 at 21:24
  • @UlrikeFischer I updated the question with a MWE when using the driver from the linked bug report and an explanation of the according behavior. I also tried re-installing MiKTeX. – Foo Bar May 12 '16 at 8:30
  • As I already wrote: try to add \RequirePackage{luatex85} before \documentclass. – Ulrike Fischer May 12 '16 at 21:29
  • 1
    Use a local texmf tree not the main tree docs.miktex.org/2.9/manual/localadditions.html and don't forget to update the fndb -- or put the files in the folder of your document. – Ulrike Fischer May 24 '16 at 21:11
8

As an alternative to \RequirePackage{luatex85} I opted to try out the experimental miktex packages (enabled with the checkbox on the main screen of Update (Admin) for MikTeX as described and illustrated: http://miktex.org/kb/miktex-next). Then in order to ensure everything was successfully registered(?) I went to Settings (Admin) for MikTeX and on the "General" tab, I clicked RefreshFNDB.

Despite using the new experimental package of LuaTeX 0.95 I still had to copy the contents of https://sourceforge.net/p/pgf/bugs/_discuss/thread/44f8dcf2/9dc8/attachment/pgfsys-luatex.def to my texmf structure (I placed it in a secondary structure in texmf\tex and re-scanned the roots from Settings (Admin) for MikTeX on the "Roots" tab.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.