1

My index is working smoothly with the command

\makeindex 

alone. However, when I put

\usepackage{makeidx}\makeindex

compilation gives two errors as

1. Command \see already defined.
\newcommand*\see[2]{\emph{\seename} #1}
2. Command \printindex already defined.
...command\printindex{\@input@{\jobname.ind}}

Packages I am using are:

\usepackage{amsmath}%
\usepackage{amsfonts}%
\usepackage{amssymb}%
\usepackage{amsmath,amscd}%
\usepackage{amsmath,chemarrow}%
\usepackage{amsmath,thmtools}% 
\usepackage{amsmath,diagrams}%
\usepackage{amsfonts,mathrsfs}%
\usepackage{amsfonts,eucal}%
\diagramstyle[labelstyle=\scriptstyle]%
\usepackage{graphicx}%
\usepackage{xy}%
\usepackage{bez123,calc,curves,ebezier,epic,eepic,multiply,rotating}%
\usepackage[bookmarks]{hyperref}%
\usepackage{MnSymbol}%
\usepackage{etoolbox}%
\usepackage{manfnt}%
\usepackage{xcolor}%
\usepackage{slashed}
\NeedsTeXFormat{LaTeX2e}

I am curious where is the clash. I am using MikTeX 2.9 with TeXnicCenter.

  • 4
    Which class do you use? What happens, when you put \usepackage{makeidx} at the beginning? Perhaps that sequence shows you, which package makes the problem. Why do you load amsmath 5 times ans amsfonts 3 times? (That's not the problem, I just recognized it). – knut Oct 8 '11 at 14:12
  • 3
    the facilities for indexes are already built into ams document classes -- amsart, amsbook and amsproc. if you are using one of these document classes, or another built on top of one of these, you will get the errors you report. this is well documrnted. you need to say what class you are using, not just the packages. (if you are using an ams class, amsmath, amsfonts and amsthm are also built in, so need not be specified.) – barbara beeton Oct 8 '11 at 14:29
  • According to different advice I found on the internet I added an additional \usepackage{amsmath,something}. Later I have not checked if any of them were redundant. So I left them as they are, lest I lose some ornamental fascility. They are couple of lines. Hence, I understand that adding \usepackage{makeidx} does not add to options that I might have. So, thanks. – Peter Jones Oct 8 '11 at 15:14
  • Adding to @knut's comments about your use of packages, there's no need to add % at the end of all these lines. For more information, see tex.stackexchange.com/questions/7453/…. – doncherry Oct 22 '11 at 12:52
7

the facilities for indexes are already built into ams document classes -- amsart, amsbook and amsproc.

if you are using one of these document classes, or another built on top of one of these, you will get the errors you report. this is well documented.

you need to say what class you are using, not just the packages. (if you are using an ams class, amsmath, amsfonts and amsthm are also built in, so need not be specified.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.