7

This question already has an answer here:

I just updated MiKTeX packages in my workstation, and TexWorks gives the following error when I try to make pdf:

pdflatex.exe - Entry Point Not Found The procedure entry point ?WideCharToUTF8@Utils@Core@MiKTeX@@SA?AV?$basic_string@DU?$char_traits@D@std@@V?$allocator@D@2@@std@@PB_W@Z could not be located in the dynamic link library MiKTeX209-core.dll.

How can I fix that?

PS: OS - Windows 7 Pro 64-bit, MiKTeX 2.9 32-bit.

marked as duplicate by Mensch, Jagath, Andrew, Werner, Jesse Aug 16 '16 at 4:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Check for new packages in the manager, run updates as admin and user. See critical updates here. tex.stackexchange.com/a/108490/2388 – Ulrike Fischer May 12 '16 at 12:59
  • 1
    Geez. It seems like MikTeX now breaks something with every update. – marczellm May 12 '16 at 13:32
  • 1
    I was able to solve it by downloading and re-installing the latest MikTeX basic distribution. I'm not sure what caused the original issue, but it is solved now. – Oleksandr May 13 '16 at 11:16
  • 2
    I solved this by removing old bin files in C:\Users\myself\AppData\Roaming\MiKTeX\2.9\miktex\bin\x64 folder. They were not updated, but called anyway because the folder is in path. Trying "where pdflatex.exe" returned two executables, one ran ok, the other gave the mentioned error. – Boocko Oct 11 '16 at 9:52
  • 1
    @Boocko: I've just run into this problem, and your advice solved it! You should've posted it as an answer -- I would gladly upvote it. Unbeknownst to you, you've just saved my day! (And yes, I know that it's been more than a year since all this was posted here.) – zipirovich Feb 16 '18 at 20:42

Browse other questions tagged or ask your own question.