2

I use a .bib file as such:

@article{juniper,
    author = "Checkoway et al",
    title  = "A Systematic Analysis of the Juniper Dual EC Incident",
    year =   "2016",
    url = {http://eprint.iacr.org/2016/376}
}

which shows up with an empty In: () if the "year" field is empty. Or a weird In: (year) if the year is specified. Any idea on how to avoid that?

enter image description here

3

The journal (or journaltitle) field is mandatory for @article entries. So if a source wasn't published in a journal, it probably doesn't qualify as an @article. Depending on what exactly you have there you can go with the generic @misc or @online or with the more specific @report.

For me this looks like a @report

@report{juniper,
  author   = {Stephen Checkoway and Shaanan Cohney and Christina Garman and Matthew Green and Nadia Heninger and Jacob Maskiewicz and Eric Rescorla and Hovav Shacham and Ralf-Philipp Weinmann},
  title    = {A Systematic Analysis of the {Juniper} Dual {EC} Incident},
  url      = {http://eprint.iacr.org/2016/376},
  date     = {2016-04-14},
  number   = {2016/376},
  type     = {Cryptology ePrint},
}

PS: The cite function on the eprint archive suggests a @misc type.

  • awesome! Didn't know they had snippets for latex citing! This is practical. Any idea how I can avoid the url and the full list of author in \fullcite? – David 天宇 Wong May 12 '16 at 16:45
  • @David天宇Wong Probably maxcitenames=1 for the options and \AtEveryCitekey{\clearfield{url}}. – moewe May 13 '16 at 4:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.