1

I am using smartdiagram with large text width in Beamer presentation. The modules are visible but they are overlapping to each other. Below is the code-

\documentclass[11pt]{beamer}
\usetheme{Madrid}
\usepackage[utf8]{inputenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{smartdiagram}

\smartdiagramset{back arrow disabled=true,
module minimum width=4cm,
module minimum height=2cm,
text width=4cm}
\smartdiagram[flow diagram:horizontal]{
\textit{State} $S_t$\\Table tennis player decide strategy, 
The system is transferred to new state $S_{t+1}$}

Below is the output-

enter image description here

Please help.

2

You need to also specify a module x sep, the initial value is 2.75 which is not enough in your case.

\documentclass[11pt]{beamer}
\usetheme{Madrid}
\usepackage[utf8]{inputenc}
\usepackage{amsmath,lmodern}
\usepackage{amsfonts}
\usepackage{smartdiagram}    
\begin{document}

\begin{frame}
\smartdiagramset{back arrow disabled=true,
module minimum width=4cm,
module minimum height=2cm,
module x sep = 6cm,
text width=4cm}
\smartdiagram[flow diagram:horizontal]{
\textit{State} $S_t$\\Table tennis player decide strategy, 
The system is transferred to new state $S_{t+1}$}
\end{frame}

\end{document}

enter image description here

| improve this answer | |
  • Thanks. It worked. But shouldn't this be automatically calculated by smartdiagram itself? – Ravi Joshi May 14 '16 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.