1

All I want is to be able to use \guillemotleft and \guillemotright.

I'm on Ubuntu 14.04, 64-bit.

These are the packages I load, after declaring documentclass article.

\usepackage{mathtools}
\usepackage{amssymb}
\usepackage{graphicx}
\usepackage{caption}
\usepackage{subcaption}
\usepackage[margin = 0.75in]{geometry}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}

When I add that last line, though, with the fontenc, pdflatex absolutely cannot handle it. I get like a billion errors. I won't post all of them, because that would probably make this post as long as a George RR Martin novel, but here's the very first one.

kpathsea: Running mktextfm ecrm1000
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ecrm1000
This is METAFONT, Version 2.718281 (TeX Live 2013/Debian)


kpathsea: Running mktexmf ecrm1000
! I can't find file `ecrm1000'.
<*> ...ljfour; mag:=1; nonstopmode; input ecrm1000

Please type another input file name
! Emergency stop.
<*> ...ljfour; mag:=1; nonstopmode; input ecrm1000

Transcript written on mfput.log.
grep: ecrm1000.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ecrm1000' failed to make ecrm1000.tfm.
kpathsea: Appending font creation commands to missfont.log.

! Font T1/cmr/m/n/10=ecrm1000 at 10.0pt not loadable: Metric (TFM) file not fou
nd.
<to be read again> 
                   relax 
l.100 \fontencoding\encodingdefault\selectfont

?

After it's finished spitting out errors like the above, the PDF it produces has nothing but my math equations in it. There's no paragraph text or section titles or even page numbers, or anything.

I tried to use my primitive Google-fu, and searched for "Latex Font T1 not loadable Metric file not found", which returned this result, but when I tried the proposed solution, it didn't work.

Terminal input—

sudo tlmgr install ec

Terminal output—

(running on Debian, switching to user mode!)
cannot setup TLPDB in /home/jps/texmf at /usr/bin/tlmgr line 5336.

Terminal input—

sudo tlmgr install cm-super

Terminal output—

(running on Debian, switching to user mode!)
cannot setup TLPDB in /home/jps/texmf at /usr/bin/tlmgr line 5336.

I once again attempted some Google-fu, and searched "Sudo tlmgr install Cannot setup TLPDB". This led me to this question, to which one responder said that the solution was to install the package xzdec.

I therefore ran—

sudo apt-get install xzdec

And this was apparently successful. So, I attempted to install ec and cm-super again, only to receive the exact same error messages as before.

I have no idea what to do at this point.

  • Welcome to TeX SX! Did you install TeX Live, or do you have the distribution that comes with Ubuntu? – Bernard May 16 '16 at 17:19
  • Welcome, load package lmodern at the beginning. – Johannes_B May 16 '16 at 17:51
  • 1
    Your TeX installation is seriously broken, I'm afraid. – egreg May 16 '16 at 18:03
  • I bet that the OP might be using the version of texlive which comes with ubuntu, which is really old, I guess texlive vintage 2013. I have had a lot better luck installing the more recent version, instead of relying on ubuntu for this. tug.org/texlive/acquire-netinstall.html The instructions are really very well written and easy to follow. – A Feldman May 16 '16 at 23:32
  • 1
    Put 'vanilla' into the search box here and look for the first question with many votes (in the first handful of results). That will tell you what else to do to make @AFeldman 's suggestion work. But still and all, egreg is right. This shouldn't happen if your installation is working. TL 2013 isn't from the age when TeX ran on stone tablets or anything. – cfr May 17 '16 at 2:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.