2

This question has been asked in Tex.S.E. before; an answer that seems to have solved the problem for BibTex users has been given: Question mark or bold citation key instead of citation number. I use Biber and have followed every step in Paul Stanley's answer as close as possible but still encounter the same error: LaTeX Warning: Citation 'foo' on page N undefined on input line XX. LaTeX Warning: Empty bibliography on input line YY.

A .bcf file and a .pdf file are generated but in the pdf I just see the citation key in bold instead of the actual citation.

I use MikTex 2.9 + TexMaker in Windows 10. I have BibLaTex 3.3 and Biber 2.4, these are compatible with each other per Biber documentation

MWE (stolen from Can't create a bibliography using biblatex):

\documentclass[12pt,a4paper]{article}

\usepackage{cmap}                   
\usepackage{mathtext}           
\usepackage[T2A]{fontenc}       
\usepackage[utf8]{inputenc}         
\usepackage[english]{babel} 
\usepackage{indentfirst}
\frenchspacing
\usepackage{authblk}
\usepackage{titling}
\usepackage{csquotes}
\usepackage[backend=biber,bibencoding=utf8,maxcitenames=2,style=authoryear]{biblatex}
\addbibresource{biblio.bib}

\begin{filecontents}{biblio.bib}

@article{quiroga2012concept,
  title={Concept cells: the building blocks of declarative memory functions},
  author={Quiroga, Rodrigo Quian},
  journal={Nature Reviews Neuroscience},
  volume={13},
  number={8},
  pages={587--597},
  year={2012},
  publisher={Nature Publishing Group}
}
\end{filecontents}

\begin{document}
\author{John Doe}
\section{section name}
\noindent Russian text \cite{quiroga2012concept}.\par

\end{document}

I am sure I am using Biber in compilation instead of BibTex, as I have pdflatex %.tex | biber % | pdflatex %.tex | pdflatex %.tex specified in TexMaker like user John Crawford shows in Setting up TexMaker on Ubuntu "biblatex.sty not found."

Which part of Paul Stanley's answer applies to Biber? He mentioned .blg and .bst but it seems Biber doesn't generate these files.

Thanks! Any help is greatly appreciated.

Update with new error message: I followed Torbjørn T's suggestion Biblatex with Biber: Configuring my editor to avoid undefined citations and this time:

INFO - This is Biber 2.3 INFO - Logfile is 'foo.blg'
ERROR - Cannot find control file 'foo.bcf'! - did you pass the "backend=biber" option to BibLaTeX?

But the backend=biber option is right there in the \usepackage{biblatex}.

Update with no error message but no citation:

Followed Bernard's suggestion to change the BibTex configuration in TexMaker, then update MikTek. Now I have no error message - not even "citation foo undefined", but the citation still only shows the citation key. However \printbibliography prints all references.

Update: I still don't have citations but at least now the TeX document compiles and all the references in my .bib show up in the resulted .pdf.

  • Just % will do, the extensions are not necessary. – Bernard May 16 '16 at 22:25
  • Bernard - I removed the extensions and the error persists. – Alex May 16 '16 at 22:37
  • So you have pdflatex %.tex | biber % | pdflatex %.tex | pdflatex %.tex | evince %.pdf? What if you run biber from a terminal? – Torbjørn T. May 16 '16 at 22:47
  • Oh, you wont have evince on Windows, so you can remove | evince %.pdf. Don't know what viewer you have set up, but F7 is the shortcut for View PDF I believe. That shouldn't affect the warning you're seeing though. – Torbjørn T. May 16 '16 at 23:03
  • 1
    Well at least biber runs, so that is good. I don't know why it doesn't find the .bcf file though. – Torbjørn T. May 16 '16 at 23:36
0

I suspect Texmaker is configured to use a build subdirectory for output files. If it is indeed the case, the line for (Bib)latex should be

C:\Program Files\MiKTeX 2.9\/miktex/bin/x64/biber.exe" build\%

(I suppose MiKTeX is installed in the default place).

1

Answer for documentation purpose:

  1. One must explicitly make sure Biberand BibLaTeX versions are compatible with each other. That the two packages came in the same MikTeX distribution doesn't necessary mean that they will work together.

  2. Texmaker needs to be set up correctly: Setting up TexMaker on Ubuntu "biblatex.sty not found.", plus Bernard's answer if Texmaker's "Use a build subdirectory for output files" option is enabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.