15

I can't get citations to work with 32-bit MikTeX and TexMaker. It seems like my Biber and biblatex versions are out of sync but I don't know how to sync them, other than by using the "synchronize" command in the MikTeX Package Manager.

Input

\documentclass{turabian-thesis}

% PDFLaTeX
\usepackage[english]{babel}
\usepackage[utf8]{inputenc}
\usepackage{csquotes}


\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
    @book{turabian_manual_2013,
        author = {Turabian, Kate L.},
        edition = {8th edition},
        title = {A Manual for Writers of Research Papers, Theses, and Dissertations: Chicago Style for Students and Researchers},
        shorttitle = {A Manual for Writers of Research Papers, Theses, and Dissertations},
        publisher = {University of Chicago Press},
        year = {2013}}
\end{filecontents}

\usepackage{biblatex-chicago}
\addbibresource{\jobname.bib}

\begin{document}
\end{document}

Log

Process started

Use of uninitialized value $bltxversion in concatenation (.) or string at C:\Users\benna\AppData\Local\Temp\par-62656e6e61\cache-564dd4103627c1c374effa6d52fc299ad25d4d4a\inc\lib/Biber.pm line 415.

INFO - This is Biber 2.5
INFO - Logfile is 'Citation_sample.blg'
INFO - Reading 'Citation_sample.bcf'
ERROR - Error: Found biblatex control file version 3.0, expected version 3.1.
        This means that your biber (2.5) and biblatex () versions are incompatible.
        See compat matrix in biblatex or biber PDF documentation.
INFO - ERRORS: 1

Process exited with error(s)
  • 1
    You will have to use the Updater (see also here) to really update your distribution. Synchronising per se will not cause an update. See also How should one maintain and update a MiKTeX installation? (where an application of the synchronise button is explained). Please run the Updater in both Admin and User mode to make sure all packages are updated. – moewe May 17 '16 at 6:23
  • Note that you are using Biber 2.5 where for the first time a version incompatibility with biblatex is a fatal error, it used to be only a warning, but weird stuff could happen, so the developer decided to raise the badness of the error. (You are most likely using biblatex v. 3.3, but you will need version 3.4 for Biber 2.5.) – moewe May 17 '16 at 6:25
8

Depending on how you installed MiKTeX (admin or user installation) start the Windows application MiKTeX Package Manager (admin) and/or MiKTeX Package Manager.

Then you can filter the currently installed packages on your computer with the following inputs (see red markings in image: type biberto name and press filter) to first show only biber:

enter image description here

Then you can see if biberis installed (red arrow) and the installation date. If the plus sign under menu point file is blue, you can install a new version (not needed on my system ...).

Now the same with biblatex: Please see that you have to choose which parts you need to install or to make it easy: just install all of them ...

enter image description here

I underlined the important part for you red, see the inputs in red circles and the plus sign marked with a blue circle.

At last a tip: Just update all updateable package for your system, but please check that biber and biblatex are choosen. To see all installable package click on menu point edit, then Select Installable Packages.

Please report, if that helped you ...

  • Miktex Lists miktex-biber-bin as \obsolete. What replaces it? – sheß Apr 5 '19 at 9:05
  • 1
    @sheß Depends on your used version, miktex-bibtex-bin-x64-2.9 for example? But simply update your system, the Miktex console does delete and install as needed ... – Mensch Apr 5 '19 at 16:53
4

I have MikTeX 2.9 installed on Windows 10. All packages are updated (in Admin as well as in User mode). When I tried to used Biber I got an error message:

INFO - This is Biber 2.7
INFO - Logfile is 'main.blg'
INFO - Reading 'main.bcf'
ERROR - Error: Found biblatex control file version 2.9, expected version 3.3.
        This means that your biber (2.7) and biblatex () versions are incompatible.
        See compat matrix in biblatex or biber PDF documentation.
INFO - ERRORS: 1

In package manager the following versions were shown:

  • 2.7 for miktex-biber-bin-x64
  • 3.7 for biblatex

Reinstallation of these packages did not solve the problem.

I checked which biblatex file is used in the system with the following command (open cmd window and simply type this)

kpsewhich biblatex.sty

The output was:

C:/Users/xxx/AppData/Roaming/MiKTeX/2.9/tex/latex/biblatex/biblatex.sty

Folder C:/Users/xxx/AppData/Roaming/MiKTeX/2.9/ is basically used to install packages installed "on the fly".

I searched if there are other files biblatex.sty in the system and it turned out that the second copy was stored in the MikTeX installation folder:

c:\Program Files\MiKTeX 2.9\tex\latex\biblatex\

I am not sure what it means. Is it that my MikTeX installation is corrupted or I have double installation of biblatex nor what is the reason for all this.

I made a simple test. I change the folder C:/Users/xxx/AppData/Roaming/MiKTeX/2.9/tex/latex/biblatex/ name to C:/Users/xxx/AppData/Roaming/MiKTeX/2.9/tex/latex/biblatex_old/

and copy the whole folder from c:\Program Files\MiKTeX 2.9\tex\latex\biblatex\ to C:/Users/xxx/AppData/Roaming/MiKTeX/2.9/tex/latex/biblatex/

Next I cleared all generated files in my tex project folder (it is important) i.e. delete *.aux, delete *.bcf, ... etc. and recompiled the project again with pdflatex, next biber, next pdflatex

It works!

  • I have a similar setup. In my case the issue was solved by using the Miktex Update Application (Start -> Miktex Update (Admin)) and then update all packages. During the next compile I could see that miktex automatically downloaded a newer biber version and the error was gone. – Stefan Profanter Sep 27 '19 at 15:02
1

Edit:

On prompting from @moewe I agree that the most likely reason for the error messages you are receiving is that your biblatex package is not up to date. So as @moewe has suggested you should:

Update:

  1. Run the MikTeX Update tool first.
  2. Verify that you have the latest biblatex package version.

    MiKTex Package Manager > Name: Biblatex > biblatex [entry] right click > Properties. Note Version number (I'm getting version 3.4, for biblatex ).

  3. Verify your biber backend version. Open up a command console (I use powershell).

    ps> biber -v
    

    (I'm getting version 2.5, for biber)

See @moewe post for further details on updating.

Then rerun your minimal working example, with the additions I originally exemplified.

Note also sometimes you have to compile several times before all the variables in the output are properly filled in. For example, in TexStudio I had to run the Bibliography (F8) command and Build & View (F5) a few times to ensure my turabin-thesis minimal working example was formatting correctly.

Original Post:

I was able to build and view your document (as a PDF) with a few changes. I added to your document like this ...

\begin{document}

Lorem \autocite{turabian_manual_2013}.

\printbibliography

\end{document}

I also am using TeXstudio, rather than TexMaker, and I recommend it. TeXstudio comes with MiKTeX (at least my installation did).

However, I seem to recall having to ensure it was configured properly:

  • TexStudio Menu > Options > Configure TexStudio > Commands [Tab] > Biber:
  • Change blank value for "Biber:" field to "biber.exe %".

You might also have to hit the bibliography command (Tools > Bibliography [f8]) before Build & View (Tools > Build & View [F5]). Sometimes you'll need to hit Build & View twice (or more).

I relatively new to Latex/Biblatex too.

Edit:

The following might also help \UsePackage[backend=biber]{biblatex-chicago} to force the correct backend selection.

Once you get things working you might like to play with various options. For my own purposes I've found useful ...

\UsePackage[authordate,
                backend=biber,
                sorting=nyt,
                backref=true,
                alldates=iso8601,
                cmsdate=on,
                annotation=true]{biblatex-chicago}

[cmsdate specifies how entries with a origdate and date should be handled].

  • Mhh, the message quoted in the question heavily suggests that everything is set up to run Biber correctly. The only problem is that the versions of biblatex and Biber don't match. The MWE won't get us far because there are no citation or bibliography commands, that much is true. – moewe May 18 '16 at 5:36
  • @moewe the main problem is likely to be the biblatex and biber version mismatch, yes. I've updated my post to reflect this. – John Bentley May 19 '16 at 7:25
  • In case it helps, having just solved the same problem: Somehow my MikTeX installation had ended up with BibLaTeX v3.4 showing through the admin package manager (correct), and v3.1 on the unprivileged version (out of date). Presumably the userspace location takes precedence, so v3.1 was being used, thus the error – Flyto May 23 '16 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.