0

I installed MacTex-2014 on my Mac a while ago, under Yosemite, and it is installed in /usr/local/texlive/2014. I have since upgraded my OS to El Capitan.

Needing to do some work on a document, I opened up TeXShop. To my surprise (I haven't done any LaTeX work on my Mac in a while) I got a message telling me I didn't have pdflatex on my system. After reading Reconfiguring TexStudio after upgrade to OS X El Capitan, and setting a symlink called texbin in /Library/TeX to point to my MacTex installation at/usr/local/texlive/2014/bin/x86_64-darwin/, I got TeXShop working and was able to compile my document.

After using TeXShop for a short while I decided that I would prefer to use TeXstudio, which I have installed on my Windows & Linux machines, and so installed it on my Mac.

When TeXstudio opened up, it also complained about being unable to find my pdflatex install, and unfortunately set my commands in the Commands window of my preferences to <unknown>. I have since set the Commands ($PATH) variable in the Build window to point to MacTex via the symlink.

Is there a way to have these commands automatically generated? I don't know enough about how TeXstudio works to confidently do this myself. (Though I could perhaps retype OSX versions of the commands shown on my Windows machine.)

Any suggestions would be most welcome.

[There are no tags for 'El Capitan' or 'Yosemite']

3
  • You need to update MacTeX to the 2015 version and then update to the final version of that. (Or wait and install 2016.) Updating TeXShop and MacTeX should ensure that TeXShop works correctly out-of-the-box. I don't know if TeXStudio has been updated yet. This is, of course, Apple's fault for treating you as a child who should not be allowed to determine the software which runs on your own computer.
    – cfr
    May 22, 2016 at 1:21
  • Can this be done as an incremental update or will I need to download the full 2G of data?
    – gone
    May 23, 2016 at 4:53
  • I don't think you can do it incrementally, no. I haven't used MacTeX for several years, but it is basically TeX Live, so I assume it is the same.
    – cfr
    May 23, 2016 at 20:22

1 Answer 1

1

Just use the button "Restore Default" next to the command. enter image description here

Also, if you want to reset all settings, you can delete the settings file (or just the commands therein).

3
  • I kind of doubt very much this will work in this case. The issue is that the defaults will not work and not that the defaults have been lost.
    – cfr
    May 22, 2016 at 1:18
  • Unfortunately, when I click the Restore Default button, the field changed from <unknown> to blank. Looking at the texstudio.ini file didn't help either and deleting it causes the fields to be set to <unknown> again.
    – gone
    May 23, 2016 at 4:46
  • Do you use the most recent version of TeXstudio (2.10.8)? It should be fixed there. May 24, 2016 at 19:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.