4

According to this question: On pdfTeX error (font expansion): auto expansion is only possible with scalable fonts, microtype package, to get rid of the error, a scalable font must be loaded.

Package lmodern no longer seems available in MikTeX; all the "lm-something" package my repository offers are shown below: enter image description here

Given that I install cm-super font family and add \usepackage[T1]{fontenc} to my document. But the error is still there.

MWE (excerpt from overleaf user Craig's CV sample):

\documentclass[12pt,letterpaper]{moderncv}        % possible options include font size ('10pt', '11pt' and '12pt'), paper size ('a4paper', 'letterpaper', 'a5paper', 'legalpaper', 'executivepaper' and 'landscape') and font family ('sans' and 'roman')

\usepackage[T1]{fontenc}
%\usepackage{lmodern}

% modern themes
\moderncvstyle{banking}                            % style options are 'casual' (default), 'classic', 'oldstyle' and 'banking'
\moderncvcolor{blue}                                % color options 'blue' (default), 'orange', 'green', 'red', 'purple', 'grey' and 'black'
%\renewcommand{\familydefault}{\sfdefault}         % to set the default font; use '\sfdefault' for the default sans serif font, '\rmdefault' for the default roman one, or any tex font name
%\nopagenumbers{}                                  % uncomment to suppress automatic page numbering for CVs longer than one page

% adjust the page margins
\usepackage{geometry}

\usepackage{import}

% personal data
\name{My}{Name}
\title{Curriculum Vitae}                               % optional, remove / comment the line if not wanted
\address{my address, line 1, line 2, line 3, postcode}{}{}% optional, remove / comment the line if not wanted; the "postcode city" and and "country" arguments can be omitted or provided empty



%----------------------------------------------------------------------------------
%            content
%----------------------------------------------------------------------------------
\begin{document}
%\makecvtitle

Undergraduate electrical and electronic engineer completing the final year of a master's degree. 

\end{document}

What do I do to make the error go away? Thanks. Your help is appreciated.

Update: I followed the step Ulrike Fischer suggested in How do I invoke cm-super?. Now it seems cm-super is not correctly installed (I see a .pk rather than a .pfb in the log) even though I do have it in MikTek Package Manager enter image description here

I have refreshed FNDB and updated formats in MikTek Options (Admin) after installing cm-super.

Googling leads me to this , but I don't know how to follow the advice. Could someone please tell me how to execute M.A. solution "updating pdftex.map by running initexmf --mkmaps" in Windows MikTek 2.9? And what else have I missed?

  • I get no error when I run your document in texlive2016 – David Carlisle May 17 '16 at 18:17
  • @DavidCarlisle I am willing to give up on MikTek and install TexLive at this point but ctan.org is down. Ctan mirrors are still running, but the search facility of all mirrors I have tried is based on the main ctan.org and is down. I have no way to find a usable download address of TexLive now. I will try again and see if ctan.org gets back online. Thanks for your comment. – Alex May 17 '16 at 20:11
  • I didn't particularly mean you should install Tl (the results in miktex should be the same) but just mentioned which version i had used, for completeness. (ctan is planned downtime, it'll be back tomorrow morning) – David Carlisle May 17 '16 at 20:12
3

Well, I'm not sure but I think package lmodern should be part of the basic installation of MiKTeX.

Please see the following image. I called the MiKTeX Package manager and filtered for lm (Latin Modern). Then you can see if Latin Modern is installed, if you see an date in column Installed on. BTW: Do not forget to call package lmodern to activate Latin Modern in your TeX document ...

MiKTeX Package Manager Latin Modern

On the other side you should be able to install it later with the MiKTeX package manager, like you tried with cm-super.

Now to the last sentences of your question:

In windows you can open the terminal/console with:

Windows-key+R, type cmd, press enter and type the mentioned command into the new window: initexmf --mkmaps, then press enter ...

  • (+1) Apologies for confusing things. People post too quick - I can't keep up! – cfr May 17 '16 at 22:20
4

I will answer this question of my own for documentation purpose: MikTeX by default doesn't come with any scalable fonts that pdfTeX is happy with - who knows exactly what makes pdfTeX happy except cm-super... When using MikTeX, if encounter auto expansion is only possible with scalable fonts error, install cm-super fonts family, execute initexmf --mkmaps command in console, and add \usepackage[T1]{fontenc} to TeX document.

  • 1
    Are you sure it doesn't come with scalable fonts? Isn't it just that Computer Modern isn't available in scalable form? The standard postscript set are surely included, aren't they? I thought they were part of even the most basic LaTeX install. – cfr May 17 '16 at 22:21
  • @cfr Rephrased. – Alex May 17 '16 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.