0

I started using texnicenter (TXN) project with the classicthesis latex template for my dissertation. I find myself using sublime text (ST) a lot so I am trying to migrate my project to sublime text and latextools but cannot get the bibliography to show when the build is finish. I have the %!TEX root = ../mainfile.tex to all the multipart files. These are some things I have noticed:

  • When I add new entries into the .bib file they show up in the autocomplete pulldown meaning latextools recognize the bib file (i stand corrected)
  • When i build with a new citations that I just added to the bib file never shows in output until I go back to compile with TXN.
  • If I clean the project and do a fresh build using ST the bibliography page never shows until I go back to use TXN .
  • After I have compiled at least twice with TXN I can cite in ST and build and it will show correctly.

I am adding the lines covering the bibliography below

\part{Bibliography}
\cleardoublepage\include{./FrontBackmatter/Bibliography}
\addcontentsline{toc}{chapter}{\tocEntry{\bibname}}
\bibliographystyle{./FrontBackmatter/myapsrev_bckref}
\label{app:bibliography} 
\bibliography{./FrontBackmatter/Bibliography}`

Thank you very much

2
  • Got it resolved by their support. Changing the build from traditional to simplein Preferences >>> Package Settings >>> LaTeXTools >>> Settings - User got it fixed. Appreciate your help – Godey May 19 '16 at 11:08
  • 1
    Great, please write an self answer, that is welcome here to help other users with the same problem ... – Mensch May 19 '16 at 11:11
1

This is how I got it with the help of the awesome folks at latextools. Change the build from traditional to simple in Preferences >>> Package Settings >>> LaTeXTools >>> Settings - User

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.