0

I am running OS 10.10.5 (Yosemite, Mac). After update to TexShop 3.6.1, TexShop no longer works. I understand that this issue would be cured by El Capitain but that is not an option for me.

The last line in my file had local Installer[495]: Displaying 'Install Succeeded' UI. and the word "failed" never appeared in the last 500 lines of the log.

On .tex files that it once worked on, I now get /Library/TeX/texbin/pdflatex does not exist. TeXShop is a front end for TeX, but you also need a TeX distribution. Perhaps such a distribution was not installed or was removed during a system upgrade. If so, go to http://tug.org/mactex and follow the instructions to install MacTeX or BasicTeX.

I tried re-downloading and re-installing TexShop twice, without any change.

In a Terminal window I get no response to “which pdftex”

My current path settings under Engine in TexShop preferences are /Library/TeX/texbin /usr/local/bin

I’d be most grateful for any help you can offer.

1
  • 1
    Welcome to TeX - LaTeX! Have you installed/reinstalled MacTex? Commented May 23, 2016 at 16:16

2 Answers 2

1

The problem isn't with TeXShop but rather that El Capitan removes the /usr/texbin link and won't let it be re-created.

Did you install MacTeX-2015? If not please see section 8 of the `Updating For El Capitan' document linked at <http://www.tug.org/mactex/elcapitan.html>. That section contains a link to FixLinks.pkg or you can do the job yourself with some Terminal commands.

0

Hmmm.... Now I see that you are using Yosemite rather than El Capitan. Then you should have the (pdf)TeX Path setting to /usr/texbin in TeXShop->Preferences->Engine. I assume you didn't install MacTeX-2015.

1
  • I appear to have had an old version of MacTeX. I reinstalled it and all is well. Thanks so much for your help!
    – needhelp
    Commented May 24, 2016 at 20:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .