I've made this enviroment:

$\clubsuit $

And in my work I've got this output. enter image description here

How do I force the symbol to stay on the same page?

  • Your screenshot doesn't appear to be showing "Rješenje:" at the bottom of the page. Am I missing something? – Mico May 23 '16 at 18:45
  • @Mico Is it OK now? – zermelovac May 23 '16 at 18:48
  • Thanks for this update. The only way to guarantee that the entire environment, including the ending \clubsuit symbol, will be placed on one page is to place it inside a minipage environment. – Mico May 23 '16 at 18:56
  • 1
    you've given this full encouragement to start a new page. flushright begins with a trivlist, which in turn is always considered a good place for a page break. what is needed is a mechanism similar to what is used for the qed symbol for the proof of a theorem. there's discussion of that topic at How to make all theorem-like environments have an ending symbol? – barbara beeton May 23 '16 at 19:02

Try using ntheorem and the nonumberplaintheorem style. The placement of endmarks is automatic (even if the environment ends up in displayed equations). Here is a possible code:


\usepackage[thmmarks, amsmath, thref]{ntheorem}

\newtheorem{rjesenje}{\hskip\parindent Rješenje}


  \lipsum[2-6] So
    \{x  ∈ E: x = 2\} = \{2\}\text{.}


enter image description here

| improve this answer | |
  • It says: ! Package ntheorem Error: Theorem style plain already defined. – zermelovac May 23 '16 at 20:03
  • 1
    Probably you're loading amsthm. You can't use it with ntheorem. However you have a compatibility mode for ntheoremwith the amsthm option. – Bernard May 23 '16 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.