8

I recently started using Emacs/Auctex on windows 10. I am trying to compile a latex document using the command C-c C-c and it does not compile and instead just reports "TeX-master-file-ask: Master file already set" in the mini buffer. Even it says same thing for C-c C-a or just choosing from GUI Command/ Latex. How can I fix this?

If I delete this end part,

%%% Local Variables:
%%% mode: latex
%%% TeX-master: t
%%% End:

and press C-c C-c then it asks for master and then compiles.

Below are the modifications to the init file I have made,

(setq-default ispell-program-name "C:/Aspell/bin/aspell.exe")

(setq text-mode-hook '(lambda() (flyspell-mode t) ))

(setq TeX-auto-save t)
(setq TeX-parse-self t)
(setq-default TeX-master nil)
(setq TeX-PDF-mode t)

;; Turn on RefTeX in AUCTeX

(add-hook 'LaTeX-mode-hook' turn-on-reftex)

;; Activate nice interface between RefTeX and AUCTeX

(setq reftex-plug-into-AUCTeX t)

Thanks for your help.

closed as off-topic by Andrew Swann, egreg, Zarko, Henri Menke, Maarten Dhondt May 25 '16 at 7:35

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
    I'm voting to close this question as off-topic because it is due to an outdated installation – Andrew Swann May 25 '16 at 7:05
  • 4
    I don't get it. Outdated installation? I see no version number or anything. In fact, I have the same problem after updating my Tex Live installation. – martinweiss Mar 4 '18 at 19:53
  • 3
    Agreed. Same here! – Daniel Sep 1 '18 at 1:33
1

I did a uninstall, followed by restart and install again from scratch. It works now. I can compile again without issues.

Not the answer you're looking for? Browse other questions tagged or ask your own question.