Currently having problems with compiling my Master's thesis after downloading the newest version of TeXStudio and MiKTeX. The error message is as follows:

Use of \blx@bbl@verbadd@i doesn't match its definition. \verb

The only other place I found a similar question regarding this error message was found here: Biblatex: include bbl, problem with "verb" field

I am not sure how this applies to my problem, but from what I understand this is due to some problem in an external file. If you need the bibliography-entry, I can provide you with that on short notice, though it is rather long (which is why I didn't include it here in the first place).

I am using Mendeley Desktop v1.16.1 to automatically generate my BibTeX database.

I am using biblatex as follows:

\usepackage[backend = bibtex,
        style = numeric-comp,
        sorting = none,
        natbib = true,
        doi = false,
        isbn = true,
        hyperref = true]{biblatex}

I also have some code to change how the bibliography output, but I doubt it is causing the problem, as commenting it out did not help.

Hope anyone knows what causes my problem and how to fix it.


2 Answers 2


This bug is now fixed in biblatex: if you are experiencing it you should update your TeX system.

Following text is retained for historical record.

This is a bug in the BibTeX support for biblatex and is already fixed in the development version. As a temporary fix, adding


after loading biblatex should work (after LaTeX/BibTeX/LaTeX).

The detail is that in order to update the BibTeX support to bring it into line with Biber, some additional items had to be added to the .bbl file BibTeX produces. This alters an indent, which needs to be set to correctly write verbatim material. Unfortunately I overlooked that in the earlier update.

  • 1
    Thank you for the quick and easy answer! It worked brilliantly! You have no idea how relieved I am right now.
    – Simen
    May 25, 2016 at 14:42
  • I am having the same problem right now; unfortunately your fix doesn't work for me.
    – bweber
    Jul 13, 2016 at 11:05
  • @user1488118 Please open a new question showing your issue: certainly the above does work for the case reported here.
    – Joseph Wright
    Jul 13, 2016 at 13:23
  • the fix worked for me, after add the above section in my .tex file. thanks.
    – Janvb
    Jul 15, 2016 at 15:20
  • Worked for me too! (I forgot to compile bibliography beforehand, but now it's fine :) )
    – luchonacho
    Aug 29, 2016 at 18:27

Above solution did not work for me. I am using svn41193-20120634 release on openSUSE_Leap_42.2. It is probably the latest release.

Following fixed it for me. On my bibliography file bib.bib I ran the following command.

biber --tool -V bib.bib

It generated a _bibertool.bib file in current working directory. I guess this tool also fixes the offending entries. I used this file in my latex file and everything compiled just fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .