1

Recently I reinstalled Ubuntu 15.10 (after having too many problems with 16.04) and everything else I need.

I used Vim-latex to write, compile and view tex documents, and it was so easy to press F5 on an empty line to insert packages as well as environments.

At the moment, when I write document and press F5, I correctly get

\documentclass[<+options+>]{<+class+>}

\begin{document}
<++>
\end{document}

Whether or not I fill the options, class and so on, it happens that:

  • if I press on an empty line, I'm prompted to insert an environment, not a package.
  • if I type a word (e.g. babel) before \begin{document} and press , I obtain the following:

    \documentclass[<+options+>]{<+class+>}
    
    \begin{babel}
    
    \end{babel}<++>
    
    \begin{document}
    <++>
    \end{document}
    

It seems the only way to insert a package (if not by write it all on my own) is to enter :TPackage, but it's not that easy to do!

EDIT: Doing other tries, I found that before \documentclass both the methods work.

1

I found the answer by myself on GitHub. In fact, it was a bug. The problem was a missing line a file of the package. Details here; the solution simply consists in download the new version of Vim-LaTeX from GitHub.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.