1

As soon as I include the classicthesis package, all section (and sub[sub]section) numbers vanish. Minimal working example:

\documentclass{report}
\usepackage{classicthesis}
\setcounter{secnumdepth}{3}
\begin{document}
    \chapter{a chapter with a number}
    \section{a section that should have a label}
    \section*{a section that should not have a label}
    \section{another section}
    \subsection{a subsection}
\end{document}

In the output, none of the sections have a leading number (but the chapter does).

I am using the most recent version (v4.2) of classicthesis from CTAN. Document class doesn't seem to make a difference; I tried both KOMA and 'classical' classes.

I use texlive on Ubuntu, and already reinstalled everything. Getting no errors or warnings in the log. And can't for the heck of it figure out why the numbering gets suppressed.

closed as off-topic by Johannes_B, user13907, Mensch, Andrew Swann, Henri Menke May 31 '16 at 9:21

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    I get 1.1, no number, 1.2 and 1.2.1 as expected – egreg May 26 '16 at 15:09
  • 1
    Perhaps this is the titlesec bug issue. Try to update titlesec – user31729 May 26 '16 at 15:12
  • 4
    I'm voting to close this question as off-topic because the issue was a buggy version of a package. Updating the package resolved the issue. – Johannes_B May 31 '16 at 8:29
4

Christian Hupfer's suggestion did the trick - I overrode the titlesec package in the texlive folder manually with the version from CTAN, and now everything works as intended.

  • Glad it worked. Welcome to TeX.SX by the way! – user31729 May 26 '16 at 16:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.