By default, when using Lyx with the KOMA-Script Book class, the date is shown below the title and author name on the titlepage. I would like to omit the date from the titlepage. Is there a way to accomplish this? Any help is greatly appreciated! Thank you.

  • 2
    Try to add \date{} before calling \maketitle.
    – Mensch
    May 28, 2016 at 2:15
  • Thank you all for your answers! The ERT method of adding \date{} at the beginning of the document does work. Unfortunately, ERT can make the workspace a bit of a mess, so I try to avoid it when possible. This is why I've accepted G.M.'s answer as the solution -- it avoids the need for ERT. A Feldman, you did a lot of work on your answer with the specifics and the screenshots, and I want to thank you for that. To anyone in the future who would prefer to use the ERT method, yours is certainly a very comprehensive answer.
    – Aces
    May 28, 2016 at 3:34
  • Not a lot of work. As a former LyX user I completely understand.
    – A Feldman
    May 28, 2016 at 23:52

3 Answers 3


Check Documents > Settings > Suppress default date on front page.


I think it is as simple as adding the "evil red text" \date{} to your preamble. To add your ERT place the cursor before your title, Ctrl-l (that's a small "L" not a capital "I") and type \date{} into the red box, and that should do it. You can also choose the menu button marked TeX or go through your menu, Insert then TeX-Code to add your TeX. And see related A Brief History of ERT

A Latex MWE solely for illustration (and not the code LyX uses to produce the same document) is below:


    \title{Hello Cat}



    Hello Alice.


enter image description hereenter image description here


Go to Document>Settings>Document class and tick suppress default date on front page. I found this out while scouring for a simple way to get this done on this page and thought to share.

  • This is already covered in the accepted answer. Perhaps we can take your screen grab and add it to that?
    – Werner
    Oct 10, 2018 at 17:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .