4

BCOR is roughly used to correct the binding. As I am about to have a softcover binding I changed to the twoside layout of the KOMA-Script class scrbook. With the binding on the left hand side the first page is also glued on the left, the second on the right hand side.

What bugs me is the default behaviour: the text is shifting on page 1 to the left not right. (the page number seems to be ok). This website dealt with the same problem and manually adjusted it. The question is not how to change it, but why this "weird" behaviour?

enter image description here using the mwe

% test.tex

\documentclass[
12pt,
a4paper,
twoside,
%BCOR=12mm
]{scrbook}
%\KOMAoptions{appendixprefix=true}
%
%NOTE Packages, my Macros und Formatdefinitions
\usepackage[english,ngerman]{babel} % Multilingual support -> ctan.org/pkg/babel
\usepackage[T1]{fontenc}            % Allows different font encodings and hyphenation -> ctan.org/pkg/fontenc
\usepackage[utf8]{inputenc}         % Translates input encodings into LaTeX internal language
\usepackage{blindtext}

\begin{document}
    \Blindtext
\end{document}
5

Class scrbook is designed to have a titlepage, then a new page is started with headings and text or table of contents etc.

Usually a book starts on page 1 (the title page) or page I (roman number, often not printed for title page). Most of books start a new chapter on the right (odd) page and class scrbook reflect this behaviour.

The binding correction is used to mask the part of paper used to bind the several pages together. Therefore this part can not be seen by an reader. Therefore it has to be there but has not to contain printed text.

In the following MWE I added package showframe to visualize the resulting printing area and I added a titlepage. I commented the command chapter for the first run.

MWE:

\documentclass[%
  fontsize=12pt,
  paper=a4,
% twoside,   % default for scrbook!
% BCOR=12mm
]{scrbook}

%\KOMAoptions{appendixprefix=true}

\usepackage[english,ngerman]{babel}
\usepackage[T1]{fontenc}  
\usepackage[utf8]{inputenc} 

\usepackage{showframe}
\usepackage{blindtext}

\begin{document}
\title{The title}
\author{The author}
\date{today}

\maketitle

%\chapter{The first chapter}
\Blindtext
\end{document}

Compile please three times. Now check the resulting pdf. Title page is page 1, the next page 2 has the correct layout for an even page.

Result:

enter image description here

See red arrows marked the place where BCOR would be added, if you uncomment it in the code.

Now please uncomment class option BCOR and compile again. Compare both resulted pdfs. Now you can see the correctly added BCOR.

Now comment BCOR please again and uncomment command chapter, compile again. Now chapter 1 starts on page 3, because that is the designd behaviour, that chapters should start on the next odd page. KOMA-Scripts adds the relevant BCOR, if you uncomment class BCOR again and recompile ...

Please compare my pdf view with yours: I activated the "book view" to get the first page shown as one page, simular to a book. Your view shows a double side at once, therefore the pages are not shown simular to a book ...

Compare the first screenshot with this with uncommented BCOR class:

enter image description here

You see the difference? And the logical place where the BCOR has to be added (red arrows)?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.