1

I have the following Problem with verbose-ibid: whenever I autocite for the first time and indicate a page number, I get the page number of the full citation plus the one I want to cite. Example:

\documentclass[a4paper,12pt,titlepage,headings=normal]{scrartcl}
\usepackage[T1]{fontenc}
\usepackage[latin9]{inputenc} 
\usepackage[USenglish]{babel}

\usepackage{cleveref} 
\usepackage[babel,german=guillemets]{csquotes}
\usepackage[style=verbose-ibid,%
        %citestyle=authoryear-verb,%
        backend=biber,%
       %citetracker=true
       ]{biblatex}
\addbibresource{Albania.bib}

\begin{document}
This is the first citation which gives me not what I want.\autocite[860-861]{Schnytzer1978}
\end{document}

It should look like this:

Adi Schnytzer. “The Impact of Aid on Albanian Industrial Development. The Soviet Union and China as Major Trading Partners.” In: Chinese economy post-Mao. Washington D.C.: United States Congress: Joint Economic Committee, 1978, pp. 860-861.

But looks like that:

Adi Schnytzer. “The Impact of Aid on Albanian Industrial Development. The Soviet Union and China as Major Trading Partners.” In: Chinese economy post-Mao. Washington D.C.: United States Congress: Joint Economic Committee, 1978, pp. 860–880, pp. 860-861.

(Difference - page numbers printed twice: the ones I want to refer to and the ones in the bib file)

Here is the Bib entry:

@incollection{Schnytzer1978,
  address = {Washington D.C.},
  annote = {http://aleph-www.ub.fu-berlin.de/F/C5HHAU8A2EGMF3HH92B1QUPIC2TIHJG8PXHM4ET4NN7XTLE65A-05164?func=direct{\&}local{\_}base=FUB01{\&}doc{\_}number=003928891Campusbib},
  author = {Schnytzer, Adi},
  booktitle = {Chinese economy post-Mao},
  pages = {860--880},
  publisher = {United States Congress: Joint Economic Committee},
  title = {{The Impact of Aid on Albanian Industrial Development. The Soviet     Union and China as Major Trading Partners}},
  year = {1978},
}

1 Answer 1

1

You need to load the package biblatex-true-citepages-omit and pass the option citepages=omit to biblatex:

\RequirePackage{filecontents}
\begin{filecontents*}{test.bib}
@incollection{Schnytzer1978,
    address = {Washington D.C.},
    annote = {http://aleph-www.ub.fu-berlin.de/F/C5HHAU8A2EGMF3HH92B1QUPIC2TIHJG8PXHM4ET4NN7XTLE65A-05164?func=direct{\&}local{\_}base=FUB01{\&}doc{\_} number=003928891Campusbib},
    author = {Schnytzer, Adi},
    booktitle = {Chinese economy post-Mao},
    pages = {860--880},
    publisher = {United States Congress: Joint Economic Committee},
    title = {{The Impact of Aid on Albanian Industrial Development. The Soviet     Union and China as Major Trading Partners}},
    year = {1978}
}
\end{filecontents*}

\documentclass[a4paper,12pt,titlepage,headings=normal]{scrartcl}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[USenglish]{babel}

%\usepackage{cleveref}
\usepackage[babel,german=guillemets]{csquotes}
\usepackage[style=verbose-ibid,backend=biber,
                citepages=omit]{biblatex}
\addbibresource{test.bib}
\usepackage{biblatex-true-citepages-omit}

\begin{document}

This is the first citation which gives me not what I want.\autocite[860-861]{Schnytzer1978}

\printbibliography

\end{document}
1
  • Note that the citepages=omit works even without the biblatex-true-citepages-omit package, but the package extends the detection of pages a bit.
    – moewe
    Jun 2, 2016 at 7:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .