2

I am trying to create a beamer presentation on TeXMaker and the problem that I'm having is that if I try to insert any type of equation into the presentation or just anything requiring $$, for example $x^2$, TeXMaker will fail to compile the presentation. Is there something in the preamble I'm missing?

Currently I have:

\documentclass[12pt]{beamer}
\usetheme{Warsaw}
\usepackage[utf8]{inputenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{movie15}
\usepackage{hyperref}
%\usepackage{flashmovie}
\usepackage{amssymb}
\usepackage{graphicx}
\usepackage{epstopdf}
\author{...}
\title{}
%\setbeamercovered{transparent} 
%\setbeamertemplate{navigation symbols}{} 
%\logo{} 
\institute{...}
%\date{} 
%\subject{} 
\setbeamercovered{transparent} 
\setbeamertemplate{navigation symbols}{}
\begin{document}
\begin{frame}{title}
$x$
\end{frame}
\end{document}

and I thought amsmath was the main thing I should have to allow math mode?

Thanks!

closed as unclear what you're asking by user36296, Stefan Pinnow, user13907, Jesse, barbara beeton Sep 26 '16 at 15:45

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Welcome to TeX.SX! In principle, amsmath is not needed for math mode at all, but it's recommendable to use it. Concerning your issue: You've provided a fragment of code, but this does not help to solve it. The relevant code is invisible for us – user31729 May 31 '16 at 16:39
  • 1
    We really need a complete MWE, as your code fragment together with a basic documents, works fine:\documentclass{beamer} \usepackage[utf8]{inputenc} \usepackage{amsmath} \usepackage{amsfonts} \usepackage{movie15} \usepackage{hyperref} \usepackage{amssymb} \usepackage{graphicx} \usepackage{epstopdf} \begin{document} \begin{frame} $x^2$ \end{frame} \end{document} – user36296 May 31 '16 at 16:42
  • I've edited it so it now includes everything before \begin{document}. If this is still not sufficient can you specify exactly what you need me to include? Also what is a complete MWE? Thanks. – JSmith May 31 '16 at 16:47
  • 1
    That's just a warning, either ignore it or disable it with \let\Tiny=\tiny. If you use latex with beamer you have to be careful how you transform the .dvi file to .pdf. Can you try pdflatex? – user36296 May 31 '16 at 17:13
  • 1
    @samcarter I think I've finally figured out the problem. It's to do with MikTeX's font maps apparantly. If I add \usepackage{sansmathaccent} and \pdfmapfile{+sansmathaccent.map} into my document's preamble it will compile just fine. The only problem is fixing it since I cannot seem to run initexmf.exe file required to fix it. – JSmith Jun 2 '16 at 14:15