16

I've been using the biblatex package for a while, and since updating my TeX installation (post-el capitan upgrade) I have been experiencing the following.

If the following is typed:

Such and such has been said \citep[111]{citekey}.

The following text is displayed:

Such and such has been said (Author, 2016, p. 111).

And if the following is typed:

\citet[111]{citekey} has said such and such.

The following text is displayed:

Author, (2016, p. 111) has said such and such.

The citep command is working as I want it to, but I do not want a comma placed after the author's name when using the citet command. I would like it to display as follows:

Author (2016, p. 111) has said such and such. 

If I use the \citeyearpar command, it is fine, but I would rather not have to type the author's name in manually.

Here is the command placed in the preamble:

\usepackage[backend=bibtex, style=authoryear-icomp, url=true, isbn=false, natbib=true, sortcites=true, block=space, pagetracker=false, loccittracker=constrict]{biblatex}

Here is an example of an entry in my bib file (made using BibDesk):

@article{poldrack2006,
Author = {Poldrack, Russell},
Journal = {Trends in Cognitive Sciences},
Number = {2},
Pages = {59--63},
Title = {{Can cognitive processes be inferred from neuroimaging data?}},
Volume = {10},
Year = {2006}}

I have also tried changing the entry to the following:

@article{poldrack2006,
Author = {Russell Poldrack},
Journal = {Trends in Cognitive Sciences},
Number = {2},
Pages = {59--63},
Title = {{Can cognitive processes be inferred from neuroimaging data?}},
Volume = {10},
Year = {2006}}

The bibliography entry appears as follows, and is fine:

Poldrack, Russell (2006). “Can cognitive processes be inferred from neuroimaging data?” In: Trends in Cognitive Sciences 10.2, pp. 59–63.

Thank you for any help that can be offered.

11

The issue has been resolved in version 3.5 of biblatex. (At least for all standard styles. Custom styles may need further tweaks, see below.)

If you are still having this problem, please update your TeX distribution. If the issue occurs with a custom style and does not go away after updating, notify the style author.

If you are using an online service, note that Overleaf v1 still uses the now quite outdated version 3.4 (2016/05/14) of biblatex. Overleaf v2 has biblatex 2016/12/05 v3.7, where the issue should be resolved.

biblatex's new context-sensitive delimiter system is a bit confused by the two-pass structure of the \textcite macro (which internally calls the command \cbx@textcite to do all the work), you will need the line

\DeclareDelimFormat[cbx@textcite]{nameyeardelim}{\addspace}

to help it along.

As PLK notes in the comments this issue (#432) has been resolved for all the standard styles in version 3.5 of biblatex. If you use a custom style that uses the two-pass \textcite but has not been updated yet, you might need

\DeclareDelimcontextAlias{cbx@textcite}{textcite}

instead.

MWE

\documentclass{article} 

\usepackage[style=authoryear-icomp, natbib=true]{biblatex}

\addbibresource{biblatex-examples.bib}

\DeclareDelimFormat[cbx@textcite]{nameyeardelim}{\addspace}

\begin{document}
\citet{sigfridsson}

\citereset\textcite{sigfridsson}

\citereset\citep{sigfridsson}

\printbibliography
\end{document}
  • 3
    This is fixed in 3.5 DEV. A new delimiter aliasing mechanism is used which has default settings to cover this case. – PLK Jun 2 '16 at 11:51
  • 2
    How to upgrade biblatex 3.5 under Ubuntu? I have the same problem with the unwanted coma and the solution provided above does not work, so I would like to upgrade biblatex. – ben Apr 1 '17 at 3:48
  • 1
    @ben If you are using the repository version of TeX live (installed via apt get or the like) you have to wait for the Ubuntu developers to push updates (that is unlikely to happen soon). You can install vanilla TeX live instead where you can use tlmgr for updates. (I have gotten into trouble for suggesting this - one of the people involved with Ubuntu and TeX live development is not keen on this solution, but it is certainly what I would do). If you can't update and you are on 3.4 use the code from my answer. – moewe Apr 1 '17 at 10:47
  • 1
    @moewe. Thank you for your answer, but the code from your answer does not work for me - maybe I am not on 3.4. I tried to install vanilla TeX live but it's very hard for me, I followed the instructions but did not understand. Is there a link to a more user friendly way of installing vanilla TeX live? – ben Apr 1 '17 at 15:00
  • 2
    @ben The code for 3.3 can be found in golatex.de/… (sorry, it's German, the code you need is in the fourth post down '17.03.2016, 13:00') – moewe Apr 1 '17 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.