2

I am trying to produce a bibliography , using acl16 style. the code is the following:

\documentclass[11pt]{article}
\usepackage{acl2016}
\usepackage{times}
\usepackage{url}
\usepackage{latexsym}
\usepackage{booktabs}
\special{papersize=210mm,297mm}
\title{}
\author{}
\date{}
\begin{document}
\maketitle
\cite{Gusfield:97}
\bibliographystyle{acl2016}
\bibliography{example}
\end{document}

And I get the error:! LaTeX Error: Something's wrong--perhaps a missing \item. In addition: Citation Gusfield:97 on page 1 is undefined. The bib file (example.bib) is--

\bibitem[\protect\citename{Gusfield}1997]{Gusfield:97}
Dan Gusfield.
\newblock 1997.
\newblock {\em Algorithms on Strings, Trees and Sequences}.
\newblock Cambridge University Press, Cambridge, UK.

I am using MikTex 2.9 and texmaker. The bbl produces only:

\begin{thebibliography}{}

\end{thebibliography}

Any ideas on how to fix this?

Thanks

  • I assume that you have a .bib file? – user31729 Jun 2 '16 at 20:43
  • yes, the \bibliography{example}--second code block – user1807435 Jun 2 '16 at 20:44
  • 1
    Please add this example.bib to the post above. Otherwise, we can't reproduce (if at all) – user31729 Jun 2 '16 at 20:45
  • 1
    I don't think that this will work. This is no valid .bib file! – user31729 Jun 2 '16 at 20:53
  • 1
    @ChristianHupfer -- bingo! you are absolutely correct! – barbara beeton Jun 2 '16 at 21:17
4

the contents of the bibliography as shown are in the format of a .bbl file, which is the output when a .bib file is run through bibtex.

two approaches are possible:

  • wrap \begin{thebibliography} ... \end{thebibliography} around this code and insert it into your tex file in place of \bibliography{example}

  • reconstruct the .bib file in the required format and rerun bibtex.

0

I had the same issue. It seemed like for no apparent reason latex file did not compile, giving me the same error, although I had implemented everything correctly. I also checked many posts here but none of them solved my issue.

Solution:

The way I solved it was to delete the .bbl file and compiled again. You need to have at least one citation for this to work properly. otherwise again a corrupt .bbl file will be generated. I don't know why is it happening, but maybe at some point when you make a mistake in referencing a corrupted empty .bbl file is created. And even when you fix the mistake it just stays there and the compiler is not able to overwrite it. It is apparently a very common issue and I hope somebody finds the issue and fixes it.

  • I don't think, that this is the same problem. The problem of user1807435 was a broken bib-file. With a broken bib-file rerunning bibtex or biber doesn't help. If you really have the same error message from time to time and regeneration of bbl-file helps, you could have an mistake in your bib-file, that only sometimes result in an broken bib-file, or your previous bibtex (or biber) run could have been aborted (or something completely different). I don't think, this is an answer to the question. – Schweinebacke Jun 27 '17 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.