Just had a surprise. I have a section in an article followed by a figure. The text flows over a page and ... one more word on the next page (which also includes the figure).

Yes, I added a ~ before that word to make it fit on the first page but I thought LaTeX wouldn't do this (leave widow words, not even sentences)!

Is there anything in particular that needs to be enabled to avoid this? I used MikTeX 2.8 with output to PDF (both pdftex and pdflatex produced the same problem).

  • Prompted by Will Robertson's answer, I changed 'orphan' to 'widow' in the title and the question to be correct with the common understanding. Sep 16 '10 at 3:35
  • 6
    I remember which is which with the saying "orphans have no past and a broken future; widows have no future and a broken past". Not sure who to attribute it to (although Wikipedia says I could be misquoting Bringhurst). Sep 16 '10 at 4:22
  • 3
    Indeed. ;-) Bringhurst, p. 43-44: "[Orphans] have no past, but they do have a future, and they need not trouble the typographer. [...] [Widows] have a past but not a future, and they look foreshortened and forlorn."
    – lockstep
    Sep 16 '10 at 15:53
  • on that note, typographic terminology in German has a similar, even easier to remember, if somewhat more crude way of referring to these two things. An orphan is a »Schusterjunge« = a shoemaker's apprentice, for »they don't know where they're going« [as finishing your apprenticeship involves leaving home and/or an uncertain future]. A widow is a »Hurenkind« = a son of a *****, for, obviously, »they don't know where they come from«. :)
    – Nils L
    May 23 '13 at 8:54

LaTeX is set up to avoid this if possible but sometimes there just isn't a good alternative. You can suppress widow lines entirely with \widowpenalty=10000 but you'll want to have \raggedbottom enabled.

Avoiding widow words isn't as directly straightforward. You cannot automatically suppress them but you can specify that you want a final line of at least some certain length with

\parfillskip 0pt plus 0.75\textwidth

where "some certain length" is, in this case, one quarter of the text width of the document.

  • 7
    I set \widowpenalty=10000 and \clubpenalty=10000 without using \raggedbottom. You just have to be sure to pay attention to the underfull vbox warnings and rewrite some text to fix those up.
    – TH.
    Sep 16 '10 at 3:13
  • 4
    "pay attention to the ... warnings" — good advice. \raggedbottom is for those instances when you can't (or can't be bothered to) rewrite. Sep 16 '10 at 4:20

During the manual final adjustments of the manuscript, I often (as a copy editor) use \looseness=1 to make TeX try to increase the number of lines in some paragraph by 1, so that I avoid widows, orphans and underfull pages.

Lorem ipsum dolor sit amet, consectetur adipiscing elit.
Phasellus vitae mi dui.
Aliquam erat volutpat.
Vestibulum nec vehicula nisi.
Ut feugiat tortor a justo eleifend sit amet adipiscing dolor cursus.

Nullam a neque consectetur magna suscipit rhoncus.
Vivamus gravida lorem non elit bibendum ac vulputate dolor cursus.
Etiam ac sapien quis dui commodo feugiat.
Praesent sagittis mi in metus cursus rutrum.
Pellentesque faucibus aliquam quam in vestibulum.
Sed non elit eget mauris tincidunt facilisis.
Suspendisse posuere elit ac magna vestibulum pulvinar. 
  • could one use also \enlargethispage{\baselineskip}? or perhaps rather \enlargethispage{-\baselineskip}...
    – user4686
    Jan 26 '13 at 13:49
  • @jfbu Yes, one could, but the result is ugly (somehow equivalent to \raggedbottom). Very bad style IMHO.
    – yo'
    Jan 26 '13 at 13:56
  • ok, will remember to use the \looseness method if I am confronted with such a problem...
    – user4686
    Jan 26 '13 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.