1

Good morning everybody,

I've used the following file serveral times to create letters. I've never had any issues. But now, out of the sudden, I am getting the following error for each German letter (ä, ö, ü, ß):

! Package inputenc Error: Unicode char \u8:äch not set up for use with LaTeX

I am using G-Brief to create the letter. There is the code:

\documentclass[11pt]{g-brief}
\usepackage[utf8]{inputenc}
\usepackage{ngerman}
\usepackage{enumerate}
\usepackage{eurosym}
\lochermarke
\faltmarken
\fenstermarken
\trennlinien

\Name                {Musterman}
\Strasse             {Musterweg 100}
\Zusatz              {}
\RetourAdresse       {}
\Ort                 {66666 Musterhausen}
\Land                {}

\Telefon             {0180/666666}
\Telefax             {}
\Telex               {}
\HTTP                {}
\EMail                           {}

\Bank                {Muster Bank}
\BLZ                 {666666}
\Konto               {666666}

\Unterschrift        {Hans Mustermann}

\Postvermerk         {}
\Adresse             {Musteradressat\\
                                            Muster-Postfach 6666\\
                      \\
                      66666 Musterhausen
                      }

\Betreff             {Musterbetref}

\Datum               {\today}
\IhrZeichen          {}
\IhrSchreiben        {}
\MeinZeichen         {}

\Anrede              {Sehr geehrte Damen und Herren,}
\Gruss               {Mit freundlichen Grüßen}{1cm}

\Anlagen             {}
\Verteiler           {}

\begin{document}
\begin{g-brief}
Hier steht nur Quatsch. Ganz oft benutze ich ein ö oder ä. ß nicht so häufig. Nur wenn ich über Fußball schreibe. Dann bäuchte ich aber kein ü. 
\end{g-brief}
\end{document}


\endinput

Maybe there is something wrong in the settings of Texnic Center? It's been working all the time up to now. I have no clue why. Hopefully you can help me.

  • it looks like that your TeXniccenter doesn't save the source file in utf encoding. Have a look into the configuration of the editor – user2478 Jun 4 '16 at 8:26
  • No. How can I do this? – Peter Jun 4 '16 at 8:31
  • The file must be stored in a 1-byte encoding so you need to change the option to (most likely) \usepackage[latin1]{inputenc} or (better) save the file in UTF-8, also the form of the error message suggests that you have an older latex release so you could update latex (although that would not help this issue) – David Carlisle Jun 4 '16 at 9:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.