1

I have a classic install of MikTex, with all basic packages, but a lot are not found. Some managed to be found via the "package installation" window at compilation, but xcolor.sty just doesn't want to be found. The file is present on my computer but it can't be found. I have \usepackage{xcolor} on my document but it doesn't seem to do anything.

  • I tried installing it from the Internet but all mirror 404 or 'server doesn't respond'
  • I tried finding the package directory but MiKTeX 2.9/tpm/packages is "Not a local package repository" (which contains xcolor.tpm)
  • I used to be have the option "install from a random repertory" or something similar, which managed to successfully install a few packages but I don't have this option anymore, now it's either the 404-ing internet or the rep that's not a local package repo.

How can I find a package that's already installed ? All the answers I find online are for uninstalled packages. I'm on windows, and I can't seem to efficiently find packages. What should I do ?

  • Absolutely none of my packages will install. Yay latex. – Raphaël Lauras Jun 4 '16 at 22:47
  • 1
    \include{xcolor} is wrong, it should be \usepackage{xcolor} – Ulrike Fischer Jun 4 '16 at 22:52
  • Please note that the MikTeX repository is down from time-to-time. – Matsmath Jun 5 '16 at 2:19
  • I edited the post, but I did write "usepackage" and not "include" – Raphaël Lauras Jun 5 '16 at 13:39
2

A basic installation of MiKTeX means that only a part of the complete MiKTeX Distribution is installed. If you need more there is an automatic way, that MiKTeX installs needed missing packages by its own (You have to activate this while installation). Of course you need then a running internet connection to get the missing packages loaded.

That is the reason I have installed the complete MiKTeX with the net installer.

To see which packages are new or should be upgraded just start the MiKTeX package Manager. This program shows you the installed packages. Click on Edit and then Select upgradable packages.

If you start the MiKTeX Upgrade manager the program looks for allready installed packages that can be upgraded and runs afterwards a "system build run" so that new packages and formats can be recognized by MiKTeX.

To do that by your own, you need to start MiKTeX settings, then click on General and click on the two buttons under Maintenance to build a new FNDB (refresh FNDB) and Update formats.

0

We can only guess what have you got on your computer. There are at least two methods that should help.

  1. Find All programs -> MikTeX 2.9 -> Maintenance (Admin) -> Settings -> General -> Reresh FNDB.

  2. Copy xcolor.sty to the working path.

The first one is more general, but if you quickly need only a few packages to use, the second method may be a temporary solution.

  • Thanks for replying so fast ! I have refreshed FNDB, now what do I do ? I can't find the .sty file, but I have the .tpm (I read that the .sty is built from the .tpm, is that true ? If not, what is the point of the tpm if having it means the package is not installed ? – Raphaël Lauras Jun 4 '16 at 23:07
  • @RaphaëlLauras You can have it in <your MikTeX path> /macros/latex/contrib/xcolor. If not and you have problem with installing additional packages, you can load *.zip here ctan.org/pkg/xcolor and use TeX on the file with extesion .dtx. – Przemysław Scherwentke Jun 4 '16 at 23:15
  • I have no directory named 'macros' directly in the general mikTex folder. I have one on <Miktew path>/doc/generic/pgf but there's only one file, I doubt that's what you're talking about. Also I tried to install packages, and I must be really dumb because even with the readme I had no idea what to do. "Extract files" -where ? I created a random folder, don't know if I should put in in MikTex or something. "Run .ins" -I opened it with my LateX editor, now what ? The compilation doesn't work : "Can't write on xcolor.log". "Put the generated files..." -No new files were generated. – Raphaël Lauras Jun 4 '16 at 23:32
  • I managed to open the ins file (by putting it out of the admin-reserved MikTeX folder), generate files, I couldn't complete the installation (couldn't find the .dvi file) but I got the xcolor.sty file so I'll just put it in my local file where the .tex file I'm writing is. I still don't know why xcolor was there but apparently not installed (so completely unusable), and how the 'install package' thing works. It managed to install packages similar to xcolor in the beginning (present in miktex but not as .sty) and then it stopped, and once I tried the internet I couldn't go back to auto install – Raphaël Lauras Jun 4 '16 at 23:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.