4

I use biber and biblatex for my citations. Strangely, if I use the @MastersThesis{} entry, it doesn't output

[96] Firstname Lastname. “Title goes here”. Master’s thesis. University of the South Pole, YEAR.

which it should according to the biblatex manual but

[96] Firstname Lastname. “Title goes here”. MA thesis. University of the South Pole, YEAR.

In my latex file, I use the following configuration

\usepackage[autostyle]{csquotes}
\usepackage[
    backend=biber,
    style=numeric,
    citestyle=nature,
    natbib=true,
    url=false, 
    doi=true,
    eprint=false
]{biblatex}

Removing the citestyle and natbib options doesn't help. I can of course change it to "Master's thesis" using the type argument in each one of the entries. But that's annoying and I just want the default. Thanks for your help.

6
  • This is a good and specific question, but it’d be even better if you provided a full, compilable example like, for example, I did in my answer. For more tips on how to do that (in your next question ;)), see meta.tex.stackexchange.com/questions/228/…. – doncherry Jun 6 '16 at 11:30
  • 3
    You get the longer term with the option abbreviate=false -- this can affect other terms too. – Ulrike Fischer Jun 6 '16 at 11:32
  • @UlrikeFischer Thank you, Ulrike. That simple option solved my problem! – Hans Jun 6 '16 at 11:58
  • @doncherry Thanks for the info. You're right. But I was just too lazy to do that ;) – Hans Jun 6 '16 at 12:04
  • 1
    @doncherry I did it. – Ulrike Fischer Jun 16 '16 at 10:47
6

When two variants exists for a term, then you get the longer term with the option abbreviate=false -- this affects naturally all other terms too.

5

You can change the relevant bibliography string (mathesis) as described in lockstep’s answer to Guidelines for customizing biblatex styles.

\documentclass{article}
\usepackage[english]{babel}
\usepackage[autostyle]{csquotes}
\usepackage[
    backend=biber,
    style=numeric,
    citestyle=nature,
    natbib=true,
    url=false, 
    doi=true,
    eprint=false
]{biblatex}
\addbibresource{biblatex-examples.bib} % That’s a dummy database that comes with biblatex

%%%% The important part:
\DefineBibliographyStrings{english}{%
  mathesis = {Master's thesis},
}
%%%%

\begin{document}
\nocite{loh}
\printbibliography
\end{document}

screenshot

1
  • Thank you for the answer. This could solve my problem, but my preferred solution is the option abbreviate=false given by Ulrike Fischer. In that case, I can just use the defaults for the entries. – Hans Jun 6 '16 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.