0

In the following example, enabling the csquotes packages wrongly uses German quotation marks in the bibliography, although I told babel that this is English:

\documentclass{article}
\usepackage[UKenglish,german]{babel}
\usepackage{csquotes} % !
\usepackage[backend=biber,natbib=true,citestyle=verbose-ibid,isbn=false,maxnames=3,bibstyle=authoryear,useprefix=true,sorting=ydnt]{biblatex} % citereset=chapter

\begin{filecontents*}{foo.bib} 
@phdthesis{rutz2014tracing,
    AUTHOR      = {Rutz, Hanns Holger},
    TITLE       = {Tracing the Compositional Process. Sound art that rewrites its own past: formation, praxis and a computer framework},
    SCHOOL      = {Plymouth University},
    ADDRESS     = {UK},
    YEAR        = {2014},
    URL         = {http://hdl.handle.net/10026.1/3116}
}
\end{filecontents*}
\selectlanguage{UKenglish}
\addbibresource{foo.bib}

\begin{document}
\selectlanguage{german}
\section*{Publikationen}

Alle unter "`Open Access"' verfügbaren Publikationen sind unter ... verlinkt.

\selectlanguage{UKenglish}
\nocite{rutz2014tracing}
\printbibliography

\end{document}

enter image description here

As soon as I remove the csquotes packages, the quotes correctly return to English:

enter image description here

How do I fix this while keeping the csquotes package enabled?

2

Add the option autostyle to csquotes. Comment aside: the image in your post shows American quotes rather than British ones.

Note: You also may have quotes in the references sections established on a per entry language basis if you use the langid field.

\RequirePackage{filecontents}
\documentclass{article}
\usepackage[utf8]{inputenc}%
\usepackage[T1]{fontenc} %
\usepackage{lmodern}
 \usepackage[UKenglish,german]{babel}
\usepackage[autostyle]{csquotes} % !
\usepackage[backend=biber,natbib=true,citestyle=verbose-ibid,isbn=false,maxnames=3,bibstyle=authoryear,useprefix=true,sorting=ydnt]{biblatex} % citereset=chapter

\begin{filecontents*}{foo.bib}
@phdthesis{rutz2014tracing,
    AUTHOR = {Rutz, Hanns Holger},
    TITLE = {Tracing the Compositional Process. Sound art that rewrites its own past: formation, praxis and a computer framework},
    SCHOOL = {Plymouth University},
    ADDRESS = {UK},
    YEAR = {2014},
    URL = {http://hdl.handle.net/10026.1/3116}
}
\end{filecontents*}
\selectlanguage{UKenglish}
\addbibresource{foo.bib}

\begin{document}
\selectlanguage{german}
\section*{Publikationen}

Alle unter "`Open Access"' verfügbaren Publikationen sind unter ... verlinkt.

\selectlanguage{UKenglish}
\nocite{rutz2014tracing}
\printbibliography

\end{document} 

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.