0

I tried to install MiKTeX 2.9. Some information:

  • OS: Windows 7, Intel i7, 8 GB RAM.
  • MiKTeX install file: setup-2.9.5987.exe
  • Install from: local repository (downloaded first), full install.
  • Repository date: June 7 2016, version 6002
  • I previously used MiKTeX, today I just want to update the whole thing as usual. The update gave unusual error (won't compile pdflatex), so I tried to uninstall-and-install everything.

It went OK (copied all packages) but in the end it showed the error

The operation could not be completed for the following reason:

Too many open files: path="C:\MiKTeX\miktex/config\packages.ini"

Details: path="C:\MiKTeX\miktex/config\packages.ini"

Screenshot:

MiKTeX installation error

Installation log:

initializing setup service...
starting installer...
Loading package database...
starting package maintenance...
installation directory: C:\MiKTeX
package repository: D:\MiKTeX_2.9_Source
visiting repository D:\MiKTeX_2.9_Source...
repository type: local package repository
loading lightweight database...
lightweight database digest: f6ae0b4a4f8fe510da4d61a2253d6bd4
going to install 113893 file(s) (3096 package(s))
extracting files from 12many.tar.lzma...
extracting files from a0poster.cab...
extracting files from a4wide.tar.lzma...
extracting files from a5comb.tar.lzma...
extracting files from aastex.tar.lzma...
extracting files from abc.tar.lzma...
...
% SNIP
...
extracting files from zxjafbfont.tar.lzma...
extracting files from zxjafont.tar.lzma...
extracting files from zxjatype.tar.lzma...
updating package definition directory (C:\MiKTeX\tpm\packages)...
installed 115 package definition files
visiting repository D:\MiKTeX_2.9_Source...
repository type: local package repository
loading lightweight database...

Error: Too many open files: path="C:\MiKTeX\miktex/config\packages.ini"

How to proceed?

  • 2
    I get similar messages irregularly too when I open the package manager sourceforge.net/p/miktex/bugs/2499/?limit=25#c3d8/f462/1208. But they normally disappear the next time so it is difficult to make a sensible bug report. If you can reproduce it you should add a ticket to the miktex bug tracker. – Ulrike Fischer Jun 9 '16 at 9:18
  • This looks like a misleading error message. Dont trust it. – MaestroGlanz Jun 9 '16 at 11:04
  • @UlrikeFischer, I've been trying (installing fresh MiKTeX) 4 times in a row now, and still got the error message. – fajar Jun 10 '16 at 5:29
  • I have been getting similar messages when I update MiKTeX. It always works eventually if I just keep trying again. – Michael Renardy Jun 17 '16 at 2:08
  • Probably a most naïve question, but can you increase the number of open files permitted by the OS? Not a good idea if it is a misleading message as @MaestroGlanz says, of course. – cfr Jun 17 '16 at 2:20
1

I had the same problem, too. My system is Microsoft Windows 7, 64bits. I have tried to

  • 1) download MikTeX from another repository,
  • 2) reinstall it several times,
  • 3) install 32bits version,
  • 4) close all programs before installing in order to gain some memory etc, but the this problem persisted.

Finally, I solved it as follows:

  • 1) I installed the basic version of MikTex for Windows 64bit.
  • 2) I opened the MikTeX program from Start.
    • chose Maintenance (Admin) - > Settings -> Packages, checked every entry in the list below and pressed Apply.

Then, MikTeX installed all selected packages.

0

I had the same error message.

My system:

  • OS: Windows 7 64 Bit
  • MikTex: 2.9.5987 64 Bit Net Installer

Installation:

  • Started Net Installer
  • Downloaded Complete MikTex
  • Saved in local directory on a desktop folder
  • Restarted Net Installer
  • Install Complete MikTex from local directory on desktop folder in C:\Program Files\MikTex2.9\
  • Here comes the error message "Too many open files"

My attempts:

  • Reinstall MikTex 2.9.5987 64 Bit several times
  • Tried Miktex 2.9.5987 32 Bit
  • Reinstall MikTex 2.9.5987 32 Bit several times

My solution:

  • Moved the local directory from the desktop folder to C:\data\Latex\MikTex\DownloadedFiles\
  • Install as described above in C:\Program Files\MikTex2.9\

This worked for me and I hope also for you.

First time I answer a question here and I know I should not suppose but:

The solution seems to be related to the package repository. Maybe it is supposed to be "near" the installation directory to avoid this error.

From your log-file I see:

installation directory: C:\MiKTeX

package repository: D:\MiKTeX_2.9_Source

Try to move the package repository to C:\ ...

Regards,

Mathis

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.