I'm working on my second ever Latex Beamer presentation, and loving the clean, professional appearance.

All compiles into PDF format no problem, until I try to use \framezoom(the image is .jpg). This fails:

\framezoom<1><2>[border] (0cm, 0cm) (2cm, 1.5cm)

but works ok without the framezoom line. I'm using Texworks, and the last lines of the console are:

("C:\Program Files\MiKTeX 2.9\tex\latex\amsfonts\umsb.fd")
("C:\Program Files\MiKTeX 2.9\tex\latex\tipa\utipx.fd") [3] [4] [5]
<02_pa.jpg, id=50, 2377.88374pt x 2055.68pt> <use 02_pa.jpg>
Overfull \vbox (4.0187pt too high) detected at line 77
[6 <C:/Documents and Settings/Owner/My Documents/Beamer/02_pa.jpg>] [7]
[8] [9] [10] [11]
Runaway argument?
border] (0cm, 0cm) (2cm, 1.5cm) \includegraphics [height=4cm]{02_pa} \ETC.
! Paragraph ended before \beamer@framezoom was complete.
<to be read again> 

I've found several examples of how to use the command, and I can't see what I'm doing wrong. Any suggestions?

  • Welcome to TeX.sx! A tip: You can use backticks ` to mark your inline code as Peter did in his edit. There's also no need to 'sign' your post as your name automatically appears.
    – Joseph Wright
    Oct 12 '11 at 19:55
  • Joseph thank you - you were correct!
    – David_UK
    Oct 12 '11 at 20:06
  • I've posted this as an answer. (I wanted to check the code before I did.)
    – Joseph Wright
    Oct 12 '11 at 20:08

I've checked the beamer code, and the problem will be the space you have in the line

\framezoom<1><2>[border] (0cm, 0cm) (2cm, 1.5cm)

after [border]. The definition of the internal \beamer@framezoom macro is such that no space is allowed here, or indeed between the two sets of parentheses. Try

\framezoom<1><2>[border](0cm, 0cm)(2cm, 1.5cm)

instead of \includegraphics use the command \pgfimage. Then it should work.


\framezoom<1><2>[border](0cm, 0cm)(2cm, 1.5cm)


this worked for me.

  • Herbert thank you - it worked correctly once I had removed the spaces.
    – David_UK
    Oct 12 '11 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.