13

I have a weird problem with LaTeXiT 2.8.0 on MAC 10.11.5

It isn't rendering anymore. Even a simple \alpha isn't shown although there is no error message. I tried all different modes like Align, Display, Inline, Text and even Auto.

Rendering doesn't work

Drag and drop my old formulas from the built-in bibliography will work, formulas are rendered correctly, but pressing "LaTeX it!" button will dismiss the content without any error messages.

Can anyone help me, please?

  • Did you recently update to El Capitan? – Herb Schulz Jun 9 '16 at 16:55
  • No, I didn't update to El Capitan but I did an update using the TeX Live Utility. – J.E.K Jun 10 '16 at 7:36
19

After flailing around with this problem, I have discovered that you must first follow the instructions referenced on the "Upgrading for El Capitan" page: upgrade LaTeXit to 2.7.5, and then open the "Preferences/Typesetting" pane and clicking the "Reset..." button. This finds the locations for the installed pdflatex and Ghostscript.

However, there is one more step needed. The default Ghostscript call is listed as:

/usr/local/bin/gs-noX11

if you replace this with:

/usr/local/bin/gs

the problem is solved.

  • Welcome to TeX.SX! On my recent installation of TeX Live 2016, /usr/local/bin/gs is a symbolic link to /usr/local/bin/gs-X11. I don't know whether the installer looks whether XQuartz is installed on the machine and decides consequently. – egreg Jun 9 '16 at 20:38
  • Thanks for your kind welcome. I'd still appreciate an answer to the question I asked below, that you deleted. I am not trying to be negative, I really am asking for my future edification. – Glen Jun 9 '16 at 20:44
  • 1
    Oddly, on my install, /usr/local/bin/gs is a simlink to usr/local/Cellar/ghostscript/9.19/bin/gs. Apparently, homebrew replaced the default simlink with its own. Or something. – Glen Jun 9 '16 at 20:47
  • 1
    This is not a forum; the space below questions is reserved for answers. Please ask a new question and link to this one. – egreg Jun 9 '16 at 20:47
  • 1
    @Glen: Thanks for response. Replacing the path for Ghostscript call to usr/local/bin/gs solved the problem – J.E.K Jun 10 '16 at 7:48
5

Am using El (Horrible) Capitan and I had the same problem. The only thing that solved my problem was:

$ brew link --overwrite ghostscript

How I found it? I opened the terminal typed:

$ gs

The output was

GPL Ghostscript 9.16: Can't find initialization file gs_init.ps.

1

Please go to http://www.tug.org/mactex/sierra.html and read the information there as well as the `Updating for El Capitan' document linked there.

Note: the original link (http://www.tug.org/mactex/elcapitan.html) was broken.

  • Thanks for your response. I followed the instructions 'MacTeX-2015 and El Capitan' and found that everything was already set to the right path. So there is still the same problem... no rendering, no error messages. – J.E.K Jun 10 '16 at 7:41
  • 1
    Finally changing the Ghostscript path to usr/local/bin/gs solved the problem. – J.E.K Jun 10 '16 at 7:50
  • If you had xQuartz when you installed MacTeX make sure it's updated to the latest version under El Capitan. – Herb Schulz Jun 13 '16 at 20:13
  • @HerbSchulz == authoritative source. – jvriesem Oct 19 '19 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.