3

I am trying to label some 3D figures. Here is a MWE:

\documentclass[tikz]{standalone}
\usepackage{tikz}
\usepackage{tikz-3dplot}
\usepackage{tkz-euclide}
\usetkzobj{all}
\begin{document}
\tdplotsetmaincoords{70}{110}
\begin{tikzpicture}[scale=2.54,tdplot_main_coords]
    \def\a{0.5}
    \draw[->] (0,0,0) -- (1,0,0) node[anchor=north east]{x};
    \draw[->] (0,0,0) -- (0,1,0) node[anchor=north west]{y};
    \draw[,->] (0,0,0) -- (0,0,1) node[anchor=south]{z};
    \coordinate (E) at (\a,0,0);  
    \coordinate (A) at (0,0,0);
    \coordinate (B) at (0,\a,0);
    \coordinate (C) at (0,0,\a); 
    \tkzMarkAngle[size=0.2cm,draw=red](B,A,C);
%   \tkzMarkAngle[size=0.2cm,draw=blue](C,A,E);
\end{tikzpicture}
\end{document}

This works as I'd hope: everything looks ok However, uncovering the commented line causes extra whitespace to be introduced to the left of the image. Is there any way I can disable this? I have a much more complicated image and I want to label different angles in turn, but I can't have the size changing each time: size changes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.