Presently, I am using emacs to render lots of mathematical symbols using the Tex mode, but quite often it displays simply the numerical Unicode value instead of the actual character on Windows 10. In the following I am just trying to add a subscript n. Do you have any suggestions?

enter image description here

Do I need to install some more fonts? Does anyone have any suggestions?


Thank you everyone for the quick responses. Here is what I have in my .emacs file:

(mapc 'load (file-expand-wildcards "D:/Tools/emacs-24.3/site-lisp/unicode-fonts.el"))

Where my Unicode-fonts.el file is from:



How do I update to Unicode 6 on Windows 10? This is what I get when I search for Unicode 6:




Have updated to Emacs 24.5 from Emacs 24.3 which I was using previously, and installed AucTeX according to this website:


Then I put it into TeX mode with,


Now, when I attempt to put a subscript to have subscript n, instead I still get the same box of four digits when I type,

_ m

Which as far as I understand is the way in emacs to set a subscript character in Tex mode (see https://www.gnu.org/software/emacs/manual/html_node/org/Subscripts-and-superscripts.html). What am I missing? TIA.

  • 2
    It is best to let TeX do the subscripting rather than use unicode subscripts such as U+2099 (unless you have made them active to expand to a normal subscript?) Jun 10, 2016 at 19:52
  • If you use Windows’ standard console (or any software making use of it), make sure you have the right codepage (chcp 65001) for Unicode active and use a font actually supporting it (e.g., Lucida Console. Next, check that the character you want to type is actually supported by the Unicode version known to Windows and the font (current 6.0 might not be!)
    – dariok
    Jun 10, 2016 at 19:53
  • subscript n was added at Unicode 6 so is less likely to be in fonts than the subscript numbers which were in Unicode 1 Jun 10, 2016 at 19:54
  • Unicode is not a system that you can update it's just a standard (that is ever growing) no font has all Unicode characters and clearly older Unicode versions are more likely to be supported (since characters never change once added, the list just grows bigger) so it is a matter of checking the documentation of each font to see if it covers that range. But as I say, if the intention is to use this with TeX, I wouldn't use these characters. Jun 10, 2016 at 20:12
  • subscript (or superscript) letters are very unlikely to be in fonts used with tex. for the stix fonts, this decision was made because it is impractical to encode everything that can be a sub- or superscript (and unicode will never be extended to do so), and thereby to discourage use of the limited complement of sub- and superscript letters that are encoded. (an exception has been made to include the script digits, as those are frequently used in text for footnotes. even so, those should not be used in math.) Jun 10, 2016 at 20:13

1 Answer 1


Please note that I had failed to add the auctex files to my site-lisp folder when following the instructions from https://www.gnu.org/software/auctex/download-for-windows.html. Also, I had added the following to my .emacs file:

;; Get TeX mode working with emacs
(setq TeX-auto-save t)
(setq TeX-parse-self t)
(setq TeX-save-query nil)
;(setq TeX-PDF-mode t) ;Enable this line if you want TeX mode enabled by default for all documents

Now it does a small m like this, which is not totally what I wanted, but it is better than before:

enter image description here

  • Use elpa to install auctex, that's much much easier
    – giordano
    Jun 11, 2016 at 20:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .