2

After I install the texlive 2016 (schema full), I got the error:

! Missing number, treated as zero.

by compiling the code below with lualatex::

\documentclass[]{scrbook}

\title{Test}

\begin{document}
\maketitle
test
\end{document}

There is no problem with pdflatex. Hast my file an error, or must I search the error elsewhere?

  • You need to add the instruction \usepackage{luatex85} to the preamble. – Mico Jun 11 '16 at 5:47
  • 1
    That's a small (known) bug in typearea. You can use as a workaround the class option pagesize= false to avoid the error message. – Ulrike Fischer Jun 11 '16 at 8:18
  • 1
    Use the koma-script version from the KOMA repository: see komascript.de/aktuellePakete how one can add that repository for TeXLive. – user2478 Jun 15 '16 at 18:37