0

I can compile the following example with pdflatex (even though it complains about the missing babel package) , but not lualatex from TeX Live 2016:

\documentclass{scrlttr2}
\begin{document}
\begin{letter}{Name}
    Test
\end{letter}
\end{document}

It results in the following error:

Class scrlttr2 Info: used language is `english'.
(scrlttr2)           Supported languages are: `english', `UKenglish',
(scrlttr2)           `british', `american', `USenglish', `australian`,
(scrlttr2)           `canadian', `newzealand',
(scrlttr2)           `german', `ngerman', `austrian', `naustrian',
(scrlttr2)           `swissgerman', `nswissgermsn',
(scrlttr2)           `acadian', `canadien', `francais', `french', 
(scrlttr2)           `dutch', `italian', `spanish', `polish',
(scrlttr2)           `croatian', `finnish', `norsk', `swedish',
(scrlttr2)           `czech'. `slovak'  on input line 4.

! Missing number, treated as zero.
<to be read again> 
p
l.4 \begin{document}

A number should have been here; I inserted `0'.
(If you can't figure out why I needed to see a number,
look up `weird error' in the index to The TeXbook.)

, shown as "Missing number, treated as zero. \begin{document}" in TeXstudio.

Adding

\documentclass{scrlttr2}
\usepackage{polyglossia}
\setmainlanguage[spelling=new]{german}

doesn't help.

  • 4
    I wished Markus would hurry and correct this bug ... Add \usepackage{luatex85}. – Ulrike Fischer Jun 11 '16 at 11:35
  • The bug only affects the scrlttr2 package? – A Feldman Jun 11 '16 at 13:06
  • @UlrikeFischer Dupe of lualatex MWE not working? – Johannes_B Jun 11 '16 at 17:40
  • 1
    @Johannes_B No, it is a bug (a typo) in typearea, you can get around it with luatex85 but for another reason. – Ulrike Fischer Jun 11 '16 at 22:36
  • 1
    The bug got fixed with Komascript 3.21, 2016-06-16 – MaxNoe Jun 27 '16 at 11:00