1

With increasing frequency auto-correction is suggesting and, if not caught, automatically introducing spelling mistakes in my English or German texts. Some of today's examples are (currently working on a German text)

  • "Uneindeutigkeit" corrected to "Umeindeutigkeit",
  • "Bedrohtheit" corrected to "Bedrohtet",
  • "bewertbar" corrected to "beweisbar", etc.

While the first example is a change to a definitive spelling mistake, "bewertbar" is a perfectly normal word in German that I would expect to be present in the dictionary.

At the beginning of the preamble of each text document I am defining its language for spell checking using % !TEX spellcheck = en-US %(or de-DE). I am using TeXShop 3.62 and the default spell checker on a Mac El Capitan with English set as primary language in system preferences.

Following the answer to this question Location of spelling dictionary in TeXShop on El Capitan I found that on my system ~/Library/Spelling/LocalDictionary is empty (0KB). In the same folder dynamic-text.dat opened in TextEdit shows a wild mix of English and German words, correctly and wrongly spelled, without any spaces or line breaks between them.

  • 2
    welcome to tex.sx. while it may be worthwhile to use a spelling dictionary to point out things that might need to be checked, i'd never recommend using auto-correction. it's more often the cause of "auto-corruption". – barbara beeton Jun 13 '16 at 19:03
  • 1
    Auto–correction is not the same thing as spell checking. Under Edit->Substitutions uncheck Text Replacement. Even better, uncheck `Correct spelling automatically' in System Preferences->Keyboard->Text. – Herb Schulz Jun 13 '16 at 22:54
  • @barbarabeeton and Herb Schulz: Thank you for your suggestions, they set me on the right path. So far I haven't a solution (there might not be one), but am starting to understand how spelling works in TeXShop. – Will Jun 14 '16 at 14:36
  • @HerbSchulz: None of the Substitution options in the Edit menu had been selected. However, in my installation the menu items Edit -> "Check Spelling While Typing" and "Correct Spelling Automatically" are marked as on per default when I start TeXShop. Deselecting the latter stopped auto-correction. Keeping "Check Spelling While Typing" provides the highlighting of spelling mistakes that I want. The problem that persists is that the underlying system-wide dictionaries/word lists (en, de) are not really useful. They miss misspelled, but underline correct words. Is this why people use cocoaspell? – Will Jun 14 '16 at 15:06
  • The problems with Apple's build-in dictionaries seem to be more general, there are several threads on them, e.g. [tidbits.com/article/16241] , [amsys.co.uk/2012/11/unlearn-spellings-on-os/] , or [superuser.com/questions/922095/… . Unfortunately, none of the suggestions work for me or apply to my situation. Hence the question about cocoaspell, any other alternative, or a way to find and "repair" the used dictionaries/word lists. – Will Jun 14 '16 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.