0

I've been trying to use bibliography in a beamer document. I have tried in many ways and does not work at all. Here is an example of the document

    \documentclass{beamer}
    \usepackage[backend=biber,style=apa]{biblatex}
    \DeclareLanguageMapping{american}{american-apa}
    \addbibresource{References.bib}
    \renewcommand*{\finalnamedelim}{%
      \ifnumgreater{\value{liststop}}{2}{\finalandcomma}{}%
      \addspace \&\space}%
    \DefineBibliographyStrings{english}{%
      references = {Bibliografía Propuesta},
    }        
    \usepackage[utf8]{inputenc}
    \usepackage[T1]{fontenc}
    \usepackage[spanish]{babel}
    \usetheme{Singapore}    
    \usefonttheme{serif}
    \usepackage{amsmath}    
    \usepackage{amsthm, amssymb}
    \begin{document}
    \begin{frame}
     \cite{*}
     \end{frame}
    \begin{frame}[allowframebreaks]
    \printbibliography
    \end{frame}
    \end{document}

I have only problems with beamer with other documents works well.

Here an example of one entry of the file References.bib

        @article{granger1981,
        title={Some properties of time series data and their use in econometric model specification},
        author={Granger, Clive WJ},
        journal={Journal of econometrics},
        volume={16},
        number={1},
        pages={121--130},
        year={1981},
        publisher={Elsevier}
      }

The file gives the following message

     Empty bibliography

Can someone help me?

ps: I have tried many similar questions on this site, so it is not a duplicate question.

  • 2
    You must \cite the reference or use \cite{*} for all references. – Herb Schulz Jun 13 '16 at 19:59
  • Yes, i did it. I'll edit the question – Héctor Jun 13 '16 at 20:03
  • 2
    you have tagged the question bibtex but the markup you are using will not work with bibtex you have backend=biber so you must use biber instead – David Carlisle Jun 13 '16 at 20:10
  • So is the problem solved? I'm assuming so from your comments, but not sure. – cfr Jun 14 '16 at 1:41
  • 1
    Please show the blg file. – Johannes_B Jun 14 '16 at 7:47
0

Here the answer to my question: Answer. Simply use PdfLaTeX+Bib(la)tex+PdfLaTeX(x2)+View Pdf in the quick compilation settings of TexMaker

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.