It seems like there used to be a working solution but I guess it stopped working with updates to biblatex:


Maybe someone is able to update the solution or suggest a new one?


This answer assumes biblatex version >= 3.4.

We will have to change the code so it complies to the new name format (cf. Biblatex 3.3 name formatting). Furthermore I have changed the code to use name hashes instead of relying on string comparison.

The code implements a new option nametracker. If set to context names will be tracked separately for the text and footnotes, if set to global (or true) names will not be tracked separately. Of course that option can only be executed after it is defined. So in the MWE it can not be set at loading-time, it can only be set with \ExecuteBibliographyOptions.


\usepackage[style=authoryear, backend=biber]{biblatex}



















Michel Goossens, Frank Mittelbach and Alexander Samarin 1994

Goossens, Mittelbach and Samarin 1994

Donald E. Knuth 1984

Knuth 1986

  • Unfortunately, the solution does not play well with style=verbose. It always gives the full name not just the first instance in this case. I am not sure where the problem is.
    – Daniel
    Jun 14 '16 at 17:01
  • 1
    @Daniel The uniquename feature needs to be turned on: add the option uniquename=true for verbose where it is not turned on by default (unlike for authoryear). Maybe you also need \renewbibmacro*{cite:full}{% \usebibmacro{cite:full:citepages}% \printtext[bibhypertarget]{% \usedriver {\DeclareNameAlias{sortname}{labelname}} {\thefield{entrytype}}}% \usebibmacro{shorthandintro}} (i.e. use labelname instead of default for sortname in the full citations).
    – moewe
    Jun 14 '16 at 17:16
  • Thanks a lot. Adding uniquename=true to the biblatex options did the trick.
    – Daniel
    Jun 14 '16 at 17:19
  • 1
    @Daniel You will also need the other modification for a few corner cases, though. (Try \cite{knuth:ct:a} and then \cite{knuth:ct:b} only if you also add the second bit of code will you get to see "Knuth ..." in knuth:ct:b, if you don't use it you will see Donald E. Knuth also for knuth:ct:b, but maybe that is what you want.)
    – moewe
    Jun 14 '16 at 17:24
  • 1
    @Daniel Of course, the code does not track appearances in footnotes and text separately. But you can have that too. Check the edit.
    – moewe
    Jun 14 '16 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.