It is so strange that no questions on the whole website are dedicated to the Literaturnaya font (despite its frequent use in Russian documents 10 years ago or so), and only two questions reference it!

On a system with a freshly installed and updated TeXLive 2016, I copied and extracted the contents of the file lit­erat-0.2.zip from this page into the correct corresponding directories of texmf-dist (doc, fonts and tex respectively). After the three “magic” actions (Update filename DB, Rebuild all Formats and Update Font Map DB), the following MWE:

О, суд людей неправый, что пьянствовать грешно!

produces the following error via pdfLaTeX (copying only the relevant part of the log where it tries to load literat.sty):

Package: literat 1999/05/20 v0.2 ParaGraph Literaturnaya as default upright
) (./literat.aux)
\openout1 = `literat.aux'.

LaTeX Font Info:    Checking defaults for OML/cmm/m/it on input line 8.
LaTeX Font Info:    ... okay on input line 8.
LaTeX Font Info:    Checking defaults for T1/cmr/m/n on input line 8.
LaTeX Font Info:    ... okay on input line 8.
LaTeX Font Info:    Checking defaults for OT1/cmr/m/n on input line 8.
LaTeX Font Info:    ... okay on input line 8.
LaTeX Font Info:    Checking defaults for OMS/cmsy/m/n on input line 8.
LaTeX Font Info:    ... okay on input line 8.
LaTeX Font Info:    Checking defaults for OMX/cmex/m/n on input line 8.
LaTeX Font Info:    ... okay on input line 8.
LaTeX Font Info:    Checking defaults for U/cmr/m/n on input line 8.
LaTeX Font Info:    ... okay on input line 8.
LaTeX Font Info:    Checking defaults for T2A/cmr/m/n on input line 8.
LaTeX Font Info:    ... okay on input line 8.
LaTeX Font Info:    Try loading font information for T2A+tli on input line 8.

File: t2atli.fd 1999/05/20 Fontinst v1.902 font definitions for T2A/tli.
) [1

{c:/texlive/2016/texmf-var/fonts/map/pdftex/updmap/pdftex.map}] (./literat.aux
LaTeX Font Info:    Try loading font information for OT1+tli on input line 3.

File: ot1tli.fd 1999/05/20 Fontinst v1.902 font definitions for OT1/tli.
)) ) 
Here is how much of TeX's memory you used:
 1729 strings out of 494319
 17975 string characters out of 6169309
 70210 words of memory out of 5000000
 5095 multiletter control sequences out of 15000+600000
 7184 words of font info for 20 fonts, out of 8000000 for 9000
 452 hyphenation exceptions out of 8191
 23i,4n,23p,200b,131s stack positions out of 5000i,500n,10000p,200000b,80000s

!pdfTeX error: pdflatex.exe (file rtlir6i): Font rtlir6i at 600 not found
 ==> Fatal error occurred, no output PDF file produced!

In addition to the log output, these are the messages from the console:

pdflatex.exe -synctex=1 -interaction=nonstopmode "literat".tex

name = rtlir6i, rootname = rtlir6i, pointsize = mktexmf: empty or non-existent rootfile!

Cannot find font rtlir6i in map file(s).

kpathsea: Running mktexmf rtlir6i.mf The command name is C:\texlive\2016\bin\win32\mktexmf
Cannot find rtlir6i.mf . I try ps2pk --> gsftopk --> ttf2pk --> hbf2gf. ps2pk cannot be used.
I try gsftopk. gsftopk.exe rtlir6i 600 gsftopk cannot be used.
Next I try ttf2pk. ttf2pk.exe -q rtlir6i 600 ttf2pk failed.
Finally I try hbf2gf. hbf2gf.exe -q -p rtlir6i 600 All trials failed.

kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 rtlir6i
The command name is C:\texlive\2016\bin\win32\mktexpk kpathsea: 
Appending font creation commands to missfont.log.

In an attempt to reproduce this example, I reëncoded the .tex file as cp1251 and tried \usepackage[cp1251]{inputenc} — to no avail. Then, I tried OT1 with the same amout of success. Only commenting out the line loading the font helped to produce the “default” document.

Processing it through latex.exe and opening the resulting DVI in the viewer produces a bunch of messages like:

Searched C:\Users\admin\.texlive2016\texmf-var\fonts\pk\\...
Searched C:\texlive\2016\texmf-var\fonts\pk\\...
Searched C:\texlive\2016\texmf-dist\fonts\tfm\\...

What could have changed in 1.5 years since January 2015 and @egreg's answer? How does one properly configure the literat font and make it work (if only it were possible not only to make it work, but also to make microtype work with it, as it normally re-scales alien/unknown fonts with default parameters)?

  • 1
    I did the installation and it seems to work flawlessly. You seem not to have updated the map file; however, adding \pdfmapfile{+literat.map} at the start of the document avoids the need. – egreg Jun 14 '16 at 22:28
  • Running updmap-sys for the second time (via the TeXLive manager menu option) did not help... neither did texhash. But the inclusion of the line you suggested really helped! Thank you! Could you please post your reply as an answer so that I could close it and mark as solved? – Andreï Kostyrka Jun 14 '16 at 22:48
  • You shouldn't have installed the files under 2016/texmf-dist: the preferred place is under texmf-local. And you should add the line literat.map to /usr/local/texlive/texmf-local/web2c/updmap.cfg (creating the file if not existent) before running updmap-sys. – egreg Jun 14 '16 at 22:52

The files should not go under .../texlive/2016/texmf-dist/, but under .../texlive/texmf-local. The main tree is only for things in the official distribution: changing it might leave an unstable TeX system.

Installing the files in the “distribution” tree has the consequence that everything has to be redone at every release of TeX Live.

This said, the procedure is:

  1. copy the relevant files in the appropriate directories in the local tree, that is, under .../texlive/texmf-local/ (creating the necessary directory structure)

  2. edit the file .../texmf-local/web2c/updmap.cfg by appending the line literat.map (creating the file if necessary)

  3. run mktexlsr

  4. run updmap-sys

The “local” updmap.cfg file avoids the need to call updmap-sys --enable-map and moreover will continue to provide the map file for future releases of TeX Live.

A temporary fix is to load the map file in the document, by typing


as the first line.

  • Well, even the procedure you mentioned in great detail did not help (I cleaned out the folders pertaining to the literat package from texmf-dist, copied the structure to texmf-local, created updmap.cfg with the line literat.map, ran mktexlsr and updmap-sys and the document still won’t compile. Going to blame Windows (why not?). However, the temporary fix works flawlessly. “There is nothing more permanent than a temporary solution.” Thank you very much! I shall try the procedure under Linux to see if it helps. – Andreï Kostyrka Jun 14 '16 at 23:14
  • @AndreïKostyrka Does this question apply? – cfr Jun 15 '16 at 3:43
  • Can you show the output of the updmap-sys run. Do you have old files in TEXMFVAR (.texlive2016 or so)? Did you ever run updmap without the -sys part? – norbert Jun 15 '16 at 9:25
  • @norbert According to c:/texlive/2016/texmf-var/fonts/map/pdftex/updmap/pdftex.map in the log file, the global map file is used. – egreg Jun 15 '16 at 9:38
  • I still need to see which updmap.cfg files were used during the run. – norbert Jun 15 '16 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.