4

First off, I am using TeXstudio, in case that information is important.

After searching for hours, I was so deseperate that I simply took the example from this question, tried to run it and it doesn't work. So what I have is this:

%bibtest.tex
\documentclass[a4paper,12pt]{scrartcl}
%\usepackage[style=authoryear, backend=bibtex]{biblatex} %produces errors
\usepackage[style=authoryear]{biblatex}
\usepackage{hyperref}
\addbibresource{biblio.bib}

\title{Minimal test}
\date{}

\begin{document}
    \maketitle
    Lorem ipsum ...\cite{Google5gram}
    \printbibliography
\end{document}

%%%%%%%%%%

%biblio.bib
@ONLINE{Google5gram,
    author = {Alex Franz and Thosten Brants},
    organization = {Google Machine Translation Team},
    url = {http://googleresearch.blogspot.com/2006/08/all-our-n-gram-are-belong-to-you.html},
    title = {All Our N-Gram are Belong to You},
    month = aug,
    year = {2006},
}

But the resulting document has no bibliography though the text has a citation tag.

enter image description here

And the compiler runs multiple times, always producing the same output:

This is BibTeX, Version 0.99d (MiKTeX 2.9 64-bit)
The top-level auxiliary file: bibtest.aux
I found no \citation commands---while reading file bibtest.aux
I found no \bibdata command---while reading file bibtest.aux
I found no \bibstyle command---while reading file bibtest.aux
(There were 3 error messages)

Prozess endete mit Fehler(n)

I just don't know what I am doing wrong. I deleted all files except the two listed above, I restarted my IDE, rebooted my PC, nothing worked. I am desperate, please help!

  • 2
    I believe biblatex assumes backend=biber by default, so you need to run biber filename, not bibtex filename. Also, in \addbibresource you should include the file extension, so \addbibresource{biblio.bib}. – Torbjørn T. Jun 15 '16 at 13:51
  • I am using TeXstudio, I hope it knows what to do, because I don't. – jaySon Jun 15 '16 at 13:56
  • 1
    Alternatively you can add backend=bibtex to the options for biblatex, in which case bibtex will work. – Torbjørn T. Jun 15 '16 at 13:58
  • @TorbjørnT. adding it to the options somehow magically destroys the project. The log says: "Using fall-back BibTeX(8) backend:(biblatex) functionality may be reduced/unavailable." and "Use of \blx@bbl@verbadd@i doesn't match its definition. \verb" – jaySon Jun 15 '16 at 14:08
2
%bibtest.tex
\documentclass[a4paper,12pt]{scrartcl}
\usepackage{hyperref}
\usepackage{lipsum}
\usepackage{cite}

 \title{Minimal test}
 \date{\today}

 \begin{document}
\maketitle
\lipsum[1] \cite{wang_model_2009}

\bibliographystyle{abbrv}  
\bibliography{biblio}
 \end{document}

 %biblio.bib
 @book{wang_model_2009,
address = {London},
title = {Model {Predictive} {Control} {System} {Design} and  {Implementation} {Using} {MATLAB}®},
isbn = {978-1-84882-331-0},
publisher = {Springer London},
author = {Wang, Liuping},
year = {2009},
keywords = {Appl.Mathematics/Computational Methods of Engineering, (CAD, CAE) and Design, Computer-Aided Engineering, Control , Robotics, Mechatronics, Electrical Engineering, Engineering, Industrial and Production Engineering, Industrial Chemistry/Chemical}
}

enter image description here

  • 1
    Finally, a result I could build upon. Even the @online works as I want it to. Thanks! :D – jaySon Jun 15 '16 at 14:39
  • @jaySon FYI, the example you posted in your question works perfectly when I compile with the sequence pdflatex - biber - pdflatex. – Torbjørn T. Jun 15 '16 at 14:46
  • @TorbjørnT. Thanks for the heads up. The thing is, I don't know how to handle a LaTeX compiler so I don't know where or how I would have to run this sequence. I am using an IDE (TeXstudio), because it does its "magic" when I press F5 so I don't have to worry about that. And even more problematic is that I am running out of time and thus get closer and closer to a state where I need things to "just work". – jaySon Jun 15 '16 at 15:12
  • @jaySon I don't know if you looked at Biblatex with Biber: Configuring my editor to avoid undefined citations, but to make a somewhat recent version of TeXstudio run biber go to Options --> Configure TeXstudio --> Build, and select biber as Default bibliography tool. Also, the backend=bibtex version would probably have worked if you did Tools --> Clean auxiliary files first (should have mentioned that, sorry). But the most important thing is of course that you have a working solution (especially with deadlines looming.) – Torbjørn T. Jun 15 '16 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.