2

I am using biblatex/biber with several bibliographies for my book, and the misc-type, which is also a single bibliography (as a chapter), for legal documents. These documents often do not have a proper date or rather the date is part of the title. However, Latex gives me a "n.d." output, and I am wondering what I can do for it to not give a "n.d." when there is no year given?

enter image description here

To make clear, the reason for why I don't want to use the "year" field is that I deal with very different kinds of documents, which may either have no date or the date is in the title, because of which I prefer to simply "hard-copy" the whole thing in the "howpublished"-section and need to suppress the year, if none is provided.

MWE:

\usepackage[autocite=footnote, language=german, style=authoryear-ibid, sorting=nyt, backend=biber]{biblatex}
\usepackage[bottom]{footmisc}
\bibliography{lit.bib}
\makeindex
\begin{document}

Test\autocite[2]{draftnotice}.

\printbibliography[title={EU Legal Documents}, type=misc1]

\end{document}

My lit.bib is as follows:

@misc1{draftnotice,
    Author = {{COMMUNICATION FROM THE COMMISSION}},
    Howpublished = {Draft Commission Notice of 2014 on the notion of State aid pursuant to Article 107 (1) TFEU}}

Check out my MWE on overleaf https://www.overleaf.com/5445314wzbgkh

5
  • 1
    Could you post a minimal example?
    – Bernard
    Jun 15, 2016 at 16:46
  • Does this help?
    – kuuhkuuh
    Jun 15, 2016 at 17:20
  • 1
    Yes, but what is the @misc1 entry type?
    – Bernard
    Jun 15, 2016 at 18:00
  • I have several bibliographies, among which several bibliographies with legal documents are. misc1 is European Union legal acts, misc2 is dutch legal acts and so forth. Otherwise it is not possible to filter them out. I will probably have to apply whatever solution i get to several of the misc-types.
    – kuuhkuuh
    Jun 15, 2016 at 18:16
  • 1
    I see. I didn't know one could add digits to standard types.
    – Bernard
    Jun 15, 2016 at 18:40

1 Answer 1

2

Here is a way of selectively removing n.d.:

.bib file:

@misc1{draftnotice,
    Author = {{COMMUNICATION FROM THE COMMISSION}},
    Howpublished = {Draft Commission Notice of 2014 on the notion of State aid pursuant to Article 107 (1) TFEU}}
@BOOK{Dodgson,
    AUTHOR =    {Lewis Carroll},
    TITLE =     {The Hunting of the Snark},
    PUBLISHER = {Macmillan}

.tex file:

\documentclass[11pt, german]{book}
\usepackage[utf8]{inputenc}
\usepackage[autostyle]{csquotes}
\usepackage{babel} \usepackage[autocite=footnote, style=authoryear-ibid, sorting=nyt, backend=biber]{biblatex}
\usepackage[bottom]{footmisc}
\bibliography{mylit.bib}

\DefineBibliographyStrings{german}{%
nodate = {\ifboolexpr{test{\ifentrytype{misc1}} or test{\ifentrytype{misc5}}}{}{o\adddot D\adddot}},
}

\begin{document}

\vspace*{15cm}
Test\autocite[2]{draftnotice}. A book without date\autocite{Dodgson}.
\printbibliography[title={EU Legal Documents}, type=misc1]

\end{document}

enter image description here

13
  • 1
    I don't understand: when there's no date, you don't want n.d. to be printed only for some entry types, and want it to be printed for all other types?
    – Bernard
    Jun 15, 2016 at 18:53
  • 1
    I have a solution, but you have to repeat the test for each miscxx type.
    – Bernard
    Jun 15, 2016 at 19:56
  • 1
    Just a question: Is your document main language german?
    – Bernard
    Jun 15, 2016 at 21:07
  • 1
    What you ask is already defined for all types of entries if you load babel with the german option.
    – Bernard
    Jun 15, 2016 at 21:16
  • 1
    Sorry, I had misread your code and thought you wanted to have o. D. in all cases. I'll try to see what can be done.
    – Bernard
    Jun 15, 2016 at 21:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .