3

I'm using the \begin{multicols*}{2} environment to typeset two-column text for a cd booklet. However, the columns aren't always properly aligned vertically. Concretely, I assume that whenever there's no extra “glue” the column isn't justified vertically. The attached image shows that the right column is somewhat shorter than the left, where the space before the subsection heading is stretched out.

I have manually done \setlength{\parskip}{0pt} at some point before if that is of relevance.

How can I make multicols space out the right column (and all other affected ones) as well?

enter image description here

1 Answer 1

1

Thanks to this question I understood what's going on and how to fix it. Actually I had already given the right hint in the question:

By setting \parskip to 0pt I prevented LaTeX to use the inter-paragraph space to adjust the vertical spacing of the page. The (or rather a) solution is to use "glue" space for that length:

\setlength{\parskip}{0pt plus \smallskipamount}

allows to add up to a \smallskip between paragraphs. This makes the page align properly at the top and the bottom.


However, I could still see a better solution by also affecting the line spacing to accomodate the lines on the page. As it is now there are inconsistent gaps between the paragraphs. So instead of only making the parskips flexible I'd also like to have \baselineskip slightly flexible. Is that possible?

[Edit:]
Of course the solution is basically the same: Making \baselineskip flexible:

\setlength{\baselineskip}{9.5pt plus .15pt minus 0.1pt}

(The 9.5 points are determined through the layouts package (it's 8pt main font size).

1
  • I'm fond of \setlength{\parskip}{0pt plus 1fil} ;-) Commented Jun 16, 2016 at 19:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .