2

I consider myself somewhat of an end-user when it comes to LaTeX, so please bear with me here. I'm using the ACM template files found at http://www.acm.org/publications/proceedings-template .

In the template file, they expect me to classify my work by generating CCS Codes using the tool found at dl.acm.org/ccs.cfm.

The generated CCS code looks like this in my .tex file:

\begin{CCSXML}
    <ccs2012>
    <concept>
    <concept_id>10003120.10003121.10003128.10011755</concept_id>
    <concept_desc>Human-centered computing~Gestural input</concept_desc>
    <concept_significance>500</concept_significance>
    </concept>
    <concept>
    <concept_id>10010147.10010371.10010387.10010866</concept_id>
    <concept_desc>Computing methodologies~Virtual reality</concept_desc>
    <concept_significance>300</concept_significance>
    </concept>
    </ccs2012>
\end{CCSXML}

\ccsdesc[500]{Human-centered computing~Gestural input}
\ccsdesc[300]{Computing methodologies~Virtual reality}

\printccsdesc

However, upon building, the generated .pdf file looks like this: Overlap

If I switch the two concepts around (which I don't think is allowed since they should be sorted by significance), I get this: enter image description here

Is there anything I could do to maintain the order, yet stop the overlap?

  • i fixed the link. you could probably have done it yourself. two things were needed: the http:// at the beginning, and a space at the end before the period. if the period is "attached", a very nice "404" page comes up. – barbara beeton Jun 16 '16 at 17:42
  • since the coding is in xml, i'd be inclined to try inserting <br> between the end of the first and the beginning of the second. might not work, but worth trying, i think. – barbara beeton Jun 16 '16 at 17:46
  • Thanks for the quick reply! Unfortunately stackexchange does not allow me to create more than 2 links without sufficient reputation, so I used my 2-link quota on the images instead, so I appreciate the fix. Secondly, inserting <br> does not work unfortunately. The \ccsdesc[...] part is what actually generates the text, and not the xml itself. – pIjIN Jun 17 '16 at 10:32
  • another hackish suggestion then. try putting \newline after the first \ccsdesc. that says to leave the first line short, but that seems better than having the overrun. – barbara beeton Jun 17 '16 at 12:37
  • Adding a \newline as you say results in the error: there is no line here to end.... If I instead add it within the curly braces I get a somewhat favourable result as seen in [i.imgur.com/flyN2Ix.jpg]. Which in your opinion is the lesser of the two evils? Switching the concepts around or having that semicolon in the middle of nowhere? – pIjIN Jun 17 '16 at 12:54
1

I would suggest setting the codes ragged right for this particular case

{\raggedright\printccsdesc\par}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.