1

I recently upgraded to MacTeX 2016 but when I launch TeX Live Utility I have this message:

your tex live version is 0 but your default repository url appears to be for tex live 2016. You need to manually upgrade to a newer version of TexLive, as there will be no further upgrades to your version.

I tried to uninstall all versions of MacTeX and reinstall only the 2016 package but it keeps saying that. I am on version 1.24 of TLU. Maybe it doesn't point to the correct directory but I don't know what is the correct path.

  • I got this problem but solved it by going to the menu item Configure>Manage Repositories, choose one, then Configure>Set as Home Repository, then exit Texlive and launched it again. – brunoh Jun 18 '16 at 9:54
3

Open TeX Live Utility's Preferences window and ensure that the path is set correctly for MacTeX. Use the button to choose /Library/TeX/texbin or drop that folder on the path bar. Screenshot of Preferences

1

You probably set TeX programs: in 'TeX Live Utility->Preferences manually at some point. Please go to <http://www.tug.org/mactex/elcapitan.html> and look at section 6 of the linkedUpdating For El Capitan' document.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.