Please consider this minimal example. Compiled with XeLaTeX.

\setmathfont{XITS Math}
Test $\exists a'$.%^\prime: same.


As you can see the "prime" is too high (above the \exists symbol). The problem does not happen when using fontsize 12 pt or removing \setmathfont.

Any idea what’s wrong? What is the recommended way of changing the default font to 14 pt? I thought about using Scale (as suggested here) but I’m not sure scaling a big amount (one sixth) is recommended.

  • 2
    Tested both with XeLaTeX and LuaLaTeX, but the prime comes out right.
    – egreg
    Jun 19, 2016 at 21:16
  • I had the same question a couple years ago. See tex.stackexchange.com/q/30115/5895 the answer there will not work anymore. But at the end of question I have updated the solution to work with most recent Unicode-math
    – Yan Zhou
    Jun 19, 2016 at 21:53
  • @YanZhou: thanks. If my problem comes from too old version of my packages, as egreg suggests, then I’ll rather wait that the updates reach my distribution. I don’t understand what the patch suggested in the other answer does and I’m a bit reluctant to just work around the bug rather than properly solve it. Jun 22, 2016 at 16:24
  • You won't solve this problem by updating package (probably ever). It is typeface specific issue. See the first answer in the question I referred to for an explanation
    – Yan Zhou
    Jun 23, 2016 at 0:10
  • @YanZhou I suspect I can because the problem does not happen for egreg. By "updating package" I meant to include "update typeface". (I referred to the package distribution mechanism of the GNU/Linux distribution I use, not specifically to LaTeX distribution.) Sorry for the confusion. Jun 23, 2016 at 10:13

1 Answer 1



*File List*
scrartcl.cls    2017/04/13 v3.23 KOMA-Script document class (article)
scrkbase.sty    2017/04/13 v3.23 KOMA-Script package (KOMA-Script-dependent basics and keyval usage)
 scrbase.sty    2017/04/13 v3.23 KOMA-Script package (KOMA-Script-independent basics and keyval usage)
  keyval.sty    2014/10/28 v1.15 key=value parser (DPC)
scrlfile.sty    2017/04/13 v3.23 KOMA-Script package (loading files)
tocbasic.sty    2017/04/13 v3.23 KOMA-Script package (handling toc-files)
  size14.clo    1999/11/11 v1.4a NON-Standard LaTeX file (size option)
typearea.sty    2017/04/13 v3.23 KOMA-Script package (type area)
unicode-math.sty    2017/01/27 v0.8d Unicode maths in XeLaTeX and LuaLaTeX
 ifxetex.sty    2010/09/12 v0.6 Provides ifxetex conditional
ifluatex.sty    2016/05/16 v1.4 Provides the ifluatex switch (HO)
   expl3.sty    2017/04/01 L3 programming layer (loader) 
expl3-code.tex    2017/04/01 L3 programming layer 
l3pdfmode.def    2017/03/18 v L3 Experimental driver: PDF mode
ucharcat.sty    2015/11/19 v0.03 ucharcat for luaLaTeX (DPC)
  xparse.sty    2017/04/01 L3 Experimental document command parser
l3keys2e.sty    2017/04/01 LaTeX2e option processing using LaTeX3 keys
fontspec.sty    2017/03/31 v2.6a Font selection for XeLaTeX and LuaLaTeX
fontspec-luatex.sty    2017/03/31 v2.6a Font selection for XeLaTeX and LuaLaTeX

   tuenc.def    2017/02/22 v2.0g Standard LaTeX file
  fix-cm.sty    2015/01/14 v1.1t fixes to LaTeX
  ts1enc.def    2001/06/05 v3.0e (jk/car/fm) Standard LaTeX file
filehook.sty    2011/10/12 v0.5d Hooks for input files
filehook-scrlfile.sty    2011/01/03 v0.1 filehook patch for scrlfile package
lualatex-math.sty    2016/04/16 v1.6 Patches for mathematics typesetting with LuaLaTeX
etoolbox.sty    2017/01/02 v2.4 e-TeX tools for LaTeX (JAW)

I get

lualatex example

Same with XeLaTeX instead of LuaLaTeX. So the problem seems to be solved using updated packages.

  • You must be right. I now realize that TexLive as packaged in my Debian stable distribution (Jessie) is very old. Checking my file list with \listfiles, many packages of mine are much older than yours. I suppose my problem will be solved when switching to the upcoming Debian release (Stretch). Apr 22, 2017 at 14:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.