4

I am currently working on my master thesis for which I use LuaLaTeX and Helvetica as my main font. I include it like this:

\usepackage{fontspec}
\setmainfont{Helvetica}

This used to work quite well. Now I bought a new MacBook (with El Capitain preinstalled - my old Mac had the same OS but it was upgraded several times - don't know whether this is part of the problem). Now, luatex can not find Helvetica anymore.

After debugging for quite a while, it seems that luatex does not find the fonts which are packages in a dfont file (even though Helvetica was in a font file on my old mac as well...).

I did not find any solutions to that problem that worked for me (and most other tex.stackexchange questions are about newly installed fonts or system fonts for other operating systems). How can I debug/fix this?

5

luatex has removed the fontforge libraries and with them dfont support.

https://github.com/lualatex/luaotfload/blob/master/NEWS

there seem to be many sites and applications offering free dfont conversions, so if the font licence allows it that is a possibility, or you could use one of the many Helvetica style fonts such as Tex gyre heros or URW Nim­bus Sans which are included in texlive.

  • Thanks!! This explains why it did not work. I transformed the dfont to ttf files and installed them as a User font. I then executed luaotfload-tool --update and now it works fine. I wonder why they removed dfont support... – Markus Pilman Jun 19 '16 at 19:20
  • It says there they also removed support for PFB/PFA via FontForge libraries. Was this the sole support for type1 in LuaTeX? – cfr Jun 20 '16 at 0:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.