0

I have a bibliography with a bunch of legal documents, for which I use the misc type. I use sorting nyt. However, it does not recognise the Author "De-Minimis-Verordnung" as starting with a "d", but rather starting with an "m", which is faulty. I think biblatex thinks this "de-" is some sort of prefix. How do I turn this behavior off?

enter image description here

MWE:

\documentclass{book}
\usepackage[ngerman]{babel}
\usepackage[autocite=footnote, maxcitenames=3, language=german, style=authoryear-ibid, backend=biber, sorting=nyt]{biblatex}
\bibliography{lit.bib}

\begin{document}

Test\autocites{eukom15122009}[]{deminimisvo}[]{mitteilungsdai}

\printbibliography[title={Gesetzesmaterialien der Europ\"aischen Union}, type=misc]

\end{document}

With the following lit.bib file

@misc{eukom15122009,
    Author = {{European Commission}},
    Howpublished = {State aid},
    Year = {2009}}

@misc{deminimisvo,
    Author = {{De-minimis-Verordnung}},
    Howpublished = {Verordnung (EU) Nr. 1407/2013},
    Year = {2013}}

@misc{mitteilungsdai,
    Author = {{Mitteilung der Kommission}},
    Year = {2013}}
2

This is due to the default \DeclareNosort setting which strips two letters followed by a dash from strings before sorting. You can fix this by putting this in your preamble:

\DeclareNosort{
  \nosort{type_name}{\regexp{}}
}
  • To avoid this mixing up f.e. regular author names of the book and article type, do you have a suggestion on how to limit this command to "misc"-type documents? – kuuhkuuh Jun 20 '16 at 18:43
  • The right way to do this is to define a custom name field for entities that are not people and you can then define different nosort options for the different fields. – PLK Jun 21 '16 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.