1

This question already has an answer here:

I am not entirely sure if this is unique to the beamer class, but I am running into a plethora of errors with a variety of biblatex commands when I use the ieee style (I am relatively sure that it's a feature of the ieee style because many (including authoryear-comp) seem to work fine).

Some commands I can't seem to get working with the aforementioned combination of ieee, and beamer biblatex:

  • \cite{} works intermittently (depending on my theme)
  • adding \printbibliography breaks the success of cite when it was part of a compatible theme ***
  • parencite compile fails ***
  • fullcite compile fails ***
  • there was a redefinition of some commands in the answer to this question: biblatex-chicago \fullcite that I tried to implement because fullcite was one of the first commands I recognized wasn't working under the ieee style and i thought the custom chicago style might have had a similar underlying problem, but I don't think thats the case.

*** only worked with authoryear-comp, beamer, and biblatex

Skeleton MWE:

\documentclass{beamer}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
    @misc{A01,
        author = {Author, A. and Buthor, B. and Cuthor, C. and Duthor, D.},
        year = {2001},
        title = {Alpha},
        url = {https://tex.stackexchange.com/q/12806/510},
    }
\end{filecontents}

\usepackage[backend=biber,style=ieee]{biblatex}

\addbibresource{\jobname.bib}

%\AtEveryCitekey{\clearfield{title}}
%\AtEveryCitekey{\clearfield{url}}
%\AtEveryCitekey{\clearfield{doi}}


\setbeamertemplate{bibliography item}{}% remove article icon:  https://tex.stackexchange.com/questions/53127/removing-document-icons-from-a-bibtex-bibliography-in-beamer

\begin{document}

\begin{frame}

    Text \cite{A01}

    %Text \fullcite{A01}

\end{frame}

\begin{frame}

    \printbibliography

\end{frame}

\end{document}

This question is likely the first in what will be a series of questions as I endeavor to create a biblatex solution to implement custom compressed-full inline text citation in a beamer presentation.

marked as duplicate by Joseph Wright Jun 27 '16 at 17:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    The only problem I had with your MWE was the one described in MacTeX 2016 somehow broke a bbx. The easiest solution is to load a language package. You can not use the \DeclareFieldFormat solutions described there. You can disable title casing with \DeclareFieldFormat{titlecase}{#1} \DeclareFieldFormat{sentencecase}{#1}.) – moewe Jun 20 '16 at 5:45
  • @moewe Thanks for your comment! If I understand you right, the style I chose to use has some internally declared (titlecase & sentencecase) rules that are conflicting biblatex's internal (default) operations and need to be explicitly overwritten or provided? – EngBIRD Jun 21 '16 at 16:31
  • 1
    The style uses the macro \MakeSentenceCase*. In biblatex 3.4 that macro has a slight problem if you don't explicitly set a document language (this bug will be fixed in the upcoming version 3.5). You can thus either (1) declare a document language by loading babel/polyglossia (this will enable the macro again), or (2) get rid of \MakeSentenceCase* with the two lines I proposed above (leaving you of course with non-sentence-cased fields). – moewe Jun 21 '16 at 18:34
  • @moewe Thanks again! I should have been a little more explicit, your linked question provided that description about the babel/polyglossia (I tend to prefer polyglossia) which I found very informative, what had me thinking it was a style specific property, was the fact that some of the built in styles (authoryear-comp to be specific) worked fine. – EngBIRD Jun 21 '16 at 22:58
  • Indeed, the standard styles do not use \MakeSentenceCase* by default (still \MakeSentenceCase* is defined in the biblatex core). So with them the problem does not occur. Some custom styles such as biblatex-ieee and the one used in the other question use \MakeSentenceCase*, and then the problem creeps up. Would you say your question is a duplicate of the other one? – moewe Jun 22 '16 at 4:49