1

I'm using MiKTeX 2.9 installed on drive C:\. (win7-64bit)

In MiKTeX options menu I added a new root under E:\drive\latexfiles\
This folder looks like

/bibtex  
../bib  
../../misc  
../bst  
../../misc  
/tex  
../latex  
../../misc

My .bib-files are located in E:\drive\latexfiles\bibtex\bib\misc

I'm using

\documentclass[conference]{IEEEtran}
\bibliographystyle{IEEEtran}
\bibliography{aais}

Scenarios:

  • Whenever compiling without \bibliography{aais} it compiles fine (although without the bibliography/references of course)
  • When I put a copy of the .bib-file in the same directory as the .tex-file (which is located in a completely different folder) it compiles fine, including the bibliography
  • Whenever I try compiling without the .bib file in the same folder, bibtex can't find the file and gives error (see below)

What I'm doing:

  • Clean up the output files
  • run latex
  • run bibtex
  • get error

The error message:

Process started 
    This is BibTeX, Version 0.99d (MiKTeX 2.9 64-bit) The top-level auxiliary file: bare_conf.aux
    The style file: IEEEtran.bst I couldn't open database file aais.bib ---line 42 of file bare_conf.aux : \bibdata{aais : }
    I'm skipping whatever remains of this command I found no database files---while reading file bare_conf.aux

Warning--I didn't find a database entry for "zave1995"
Warning--I didn't find a database entry for "sommervilleSE"
Warning--I didn't find a database entry for "w3cglossary"
Warning--I didn't find a database entry for "soabook"
Warning--I didn't find a database entry for "Breivold2007"
Warning--I didn't find a database entry for "Tsai2007"
Warning--I didn't find a database entry for "Gu2009"
Warning--I didn't find a database entry for "Ikram2014"
Warning--I didn't find a database entry for "Eck2003" -- IEEEtran.bst version 1.14 (2015/08/26) by Michael Shell. -- http://www.michaelshell.org/tex/ieeetran/bibtex/ -- See the "IEEEtran_bst_HOWTO.pdf" manual for usage information. Done. (There were 2 error messages)
        Process exited with error(s)

Things I've tried:

  1. put .bib-file one folder up.
  2. erased capitals from the path/filename. No spaces.
  3. put .bib one folder up

Am I missing something here?

I have a different LaTeX document I use that uses a .cls-file from E:\drive\latexfiles\tex\latex\misc just fine.

  • 1
    Did you update the FNDB? – Ulrike Fischer Jun 21 '16 at 13:11
  • Your .bib files don't have to be under a TeX local root. – Bernard Jun 21 '16 at 13:11
  • I forgot to update the FNDB yes. Found out minutes after posting this, after hours trying to find out what exactly was happening. Thank you for the answer though – lmartinl Jun 21 '16 at 13:17
0

Solution: Click "Refresh FNDB" (accessible in Miktex settings/options. Tab General)

Presumeably, between using the other latex file and the new one, I renamed a folder when setting up bibliography synchronization with Mendeley Desktop, and forgot to refresh the FNDB.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.